Showing results for 
Search instead for 
Did you mean: 

One specific Android app can't connect to Fido Internet

I'm a Participant Level 1
I'm a Participant Level 1



I am experiencing issues with one app that can't connect to my Fido home internet and my Fido mobile internet. I've tried to use the app on Google Nexus 5 and Google Pixel 3 and both have the same issue exclusively to my fido internet, both mobile and home. The app works fine with any other wi-fi on both devices, I tried at work and at my friend's house.

What happens in the app is that it takes forever to sign me in before it gives up and shows me an error message. Since the app works on two different android devices running different os versions on any other network it leads me into thinking that there is something wrong with my internet account or Fido internet in general, not the app and not the phones I have not tried iOS devices since I don't own any.

I've tried restarting the home  internet modem but I am not sure if resetting its settings will do any help, and if they do, that won't fix the app not loading on my fido mobile wifi.


Is there a way to fix that issue?


Thank you in advance!



Hi @pkirillov! Welcome to the community. Smiley


A very odd issue indeed. What's the app you're trying to use?


Have you tried to remove the app and reinstall it?


Let us know.

Hey @pkirillov!


Let us know if you still need help with this! 


The Community is here to help!