MMS won't send when connected to WIFI

MMS won't send when connected to WIFI

MMS won't send when connected to WIFI

Bethy
I'm a Participant Level 1

MMS won't send when connected to WIFI

Hello! I'm new to Fido and have an issue with my MMS messages. Each time I try to send a picture, it will not send unless my wifi is switched off. Even then, it takes a while to push through. While I'm happy I can work around it, it's pretty annoying (especially when I forget to turn my wifi back on). Is there a way to fix this? 

 

I have a OnePlus6 phone (BYOD) and am not interested in getting a new phone. 

3 REPLIES 3
Vanisle
I'm a Participant Level 2

This happened to me several months ago and Fido customer service had to change something on their end and then it was fine.  After the latest OS update this has happened again and I can no longer send an mms unless I turn wifi off.  Oneplus6t.  Anyone have any solutions? 

Cawtau
Senior MVP

Hello Bethy,

 

  Welcome to the community!

 

  Have you had this same issue with other providers? Had your phone updated recently?

 

  I recently had a similar issue after my phone updated to Android 11. There seems to be a new setting in Android for MMS messages --> Send & Receive when mobile data is off (see graphic here). Unfortunately, I can't provide instructions to access that setting. The setting seems to be readily available to users as shown in that graphic. However, I am unable to re-locate that setting on my phone (Samsung with OneUI 3.1). When I received a MMS while on Wifi, a settings panel notification directed me to a page with that Send & Receive MMS setting. I have tried to search everywhere that comes to mind on my phone and cannot seem to find that setting again. The good news is that I can now receive MMS without having to disconnect from Wifi. However, I cannot provide detailed instructions to find that setting. Hopefully that setting is more easily found in your OnePlus 6.

 

  Others have also tried to keep Mobile data always active with some success (see here). I'm personally not a fan of this method as I prefer more control over data usage. Note the setting discussed above is different from this setting. My phone has the Send & Receive MMS when mobiledate is off as enabled and Mobile data always active as disabled.

 

Hope this helps 😀

 

Cheers

 

Cheers

 


FidoFaiza
Moderator

Hi @Bethy

 

Welcome to Community Smiley

 

To clarify, the cellular data must be ON in order to send or receive mms. In your case, are you only able to send mms if the wifi is off? 

 

Since you are using a non-Fido device and the issue involves wifi, the support we can offer is limited. I'd start by making sure the device is running on the latest OS. 

 

Anyone else in the @Community?