International texting (SMS) not working for me

Reply
Highlighted
I'm a Participant Level 2 Narmin
I'm a Participant Level 2

International texting (SMS) not working for me

My international text is not working . My phone is Samsung.  I restart the phone and entered phones number again still not working . I have unlimited text too . Please help me what to do .

Accepted Solution

Re: International texting (SMS) not working for me

Hello again,

 

  Thanks for the additional information.

 


Narmin wrote:....

01198 also +1198 also +01198 .


  I understand you have been able to make calls and text in the past. However, just to clarify, the + symbol replaces the whole IDP, not simply the 0. So for Iran, the International calling/texting format should be 01198 or +98.

 

  That said, FidoMaria noted that text messaging to Iran is not possible at this time.

 

Hope this helps Smiley

 

Cheers

View solution in context
Flag this to a Moderator
Message 1 of 7
1,462 Views
Former Moderator FidoMaria
Former Moderator

Re: International texting (SMS) not working for me

Hi @Narmin & welcome to the Community!

 

What happens exactly when you try to send an international text? Are you getting an error message? And what dialing pattern are you using?



Flag this to a Moderator
Message 2 of 7
1,458 Views
I'm a Participant Level 2 Narmin
I'm a Participant Level 2

Re: International texting (SMS) not working for me

Nothing really . I don't get delivery text . It's funny cause I don't get delivery text for canada text too except with Fido phone number . I tried to just use 0 in front of the number which I always did and never had problem then I add + in front of it still not working . Èven my MMS not working and my data phone is on too. 😭

Flag this to a Moderator
Message 3 of 7
1,452 Views
MVP
MVP

Re: International texting (SMS) not working for me

Hello Narmin,

 

  Welcome to the community!

 


@Narmin wrote:

... I don't get delivery text for canada text too except with Fido phone number . ..


  The delivery and read receipt texts are a function of the receiving provider and not sent by all providers. For example, Bell does not send the receipts once messages have been delivered and/or read to/by their customers.

 

 


@Narmin wrote:

... I tried to just use 0 in front of the number which I always did and never had problem then I add + in front of it still not working ...


  I'm not sure what you mean by using 0 in front of the number. International calling and texting requires the international dialling prefix (IDP) and country calling code (see here) . In Canada, the IDP is 011.  Since the IDPs vary by country, the International dialling prefix can be replaced by the plus symbol, +.

 

  So the proper international dialling format from Canada is 011 followed by Country Calling Code followed by Area Code followed by phone number.

 

 or + followed by Country Calling Code followed by Area Code followed by phone number from anywhere.

 

 To which country are you trying to send a SMS? Some countries (ie Ireland) have area codes with preceding zeros which are not included when using the international dialling/texting format.

 

 


@Narmin wrote:

...Èven my MMS not working and my data phone is on too...


  Have you verified that the APN settings on your device are correct? You can verify the proper settings here. **edit** You noted you have a Samsung, which one do you have (model and version)? I understand your data is enabled, however, have you tried to disable your Wifi? For some reason, my S5 will not send/receive MMS with Wifi connected, even though my data is enabled. It will send once I disable Wifi, though.**

 

Hope this helps Smiley Happy

 

Cheers



Flag this to a Moderator
Message 4 of 7
1,448 Views
I'm a Participant Level 2 Narmin
I'm a Participant Level 2

Re: International texting (SMS) not working for me

What i ment by useing + insted of 0 for contest code was exactly what you explained. It's not first time i am calling and texting but since I change the phone company they don't get the text that I am sending . Before I used 0 for first number of the code country  but someone told me to try + instead of 0 . The country that I am trying to text is Iran.  I don't have a problem when I call it's just a text that they don't get it . So I tried all of the below option still not working .

01198 also +1198 also +01198 .

 

Flag this to a Moderator
Message 5 of 7
1,420 Views
Former Moderator FidoMaria
Former Moderator

Re: International texting (SMS) not working for me

Hi @Narmin! Thanks for specifying which country you're trying to text.

 

At this current time, text messages to Iran are blocked.



Flag this to a Moderator
Message 6 of 7
1,412 Views
MVP
MVP
Solution

Re: International texting (SMS) not working for me

Hello again,

 

  Thanks for the additional information.

 


Narmin wrote:....

01198 also +1198 also +01198 .


  I understand you have been able to make calls and text in the past. However, just to clarify, the + symbol replaces the whole IDP, not simply the 0. So for Iran, the International calling/texting format should be 01198 or +98.

 

  That said, FidoMaria noted that text messaging to Iran is not possible at this time.

 

Hope this helps Smiley

 

Cheers



Flag this to a Moderator
Message 7 of 7
1,408 Views