Fido Roaming not working

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Fido Roaming not working

Pixel 1 XL going to states Las Vegas Alaska new york ect. Roaming never works despite connecting to it and turning the feature on in the phone.

 

I get the generic message 7 dollars a day to roam, which is fine. I can connect to the us carriers (AT&T, ect), but when i try to use my apps or browse on browser, there is no data.

 

Never got it to work, I even get the roaming notification email confirming a user on my account has registered on a roaming network.

 

 I worked with a support previously and they told to try to manually select another network, reset phone ect, but no avail.

 

I've noticed other people had the same issues is this on fidos end? My plan clearly has roaming.


I have an upcoming trip to vegas and need the roaming to work. Please advise

Accepted Solution

Re: Fido Roaming not working

Hello MarkLui,

 

  Welcome to the community!

 

  Your phone is able to connect to the networks and receive text messages so it appears that roaming is working. Is it only data you are unable to use? Are you able to make and/or receive calls or send text messages? Did you note to which network your phone was connected?

 

  Fido Roam is automatically enabled so there is no setting to turn on the feature. However, have you verified that your data and data roaming were enabled? Does your phone have a Data Saver setting? Some apps might not work properly if Data Saving is enabled.

 

  You might consider contacting customer service so they can access your account to verify there is no data roaming block on your account. Alternatively, you might consider sending @FidoSolutions a PM. Once they verify some information, they'll also be able to access your account.

 

Hope this helps 😀

 

Cheers

 

View solution in context
Flag this to a Moderator
Message 1 of 2
262 Views
Highlighted
Senior MVP Senior MVP
Senior MVP
Solution

Re: Fido Roaming not working

Hello MarkLui,

 

  Welcome to the community!

 

  Your phone is able to connect to the networks and receive text messages so it appears that roaming is working. Is it only data you are unable to use? Are you able to make and/or receive calls or send text messages? Did you note to which network your phone was connected?

 

  Fido Roam is automatically enabled so there is no setting to turn on the feature. However, have you verified that your data and data roaming were enabled? Does your phone have a Data Saver setting? Some apps might not work properly if Data Saving is enabled.

 

  You might consider contacting customer service so they can access your account to verify there is no data roaming block on your account. Alternatively, you might consider sending @FidoSolutions a PM. Once they verify some information, they'll also be able to access your account.

 

Hope this helps 😀

 

Cheers

 


Flag this to a Moderator
Message 2 of 2
246 Views