APN Settings Need Update Android 8.1 MMSC on 3G only no MMSC on LTE

Service interruption


An update for our valued customers: We know you depend on us and on April 19, we let you down - for this we are truly sorry. You won’t be charged for your wireless services that were impacted on Monday, April 19. A credit equivalent to that day's wireless service fee will be applied to your May bill. This will be done automatically & no action is required by you.

Click here to read more

APN Settings Need Update Android 8.1 MMSC on 3G only no MMSC on LTE

APN Settings Need Update Android 8.1 MMSC on 3G only no MMSC on LTE

SOLVED
dGio
I'm a Contributor Level 1

APN Settings Need Update Android 8.1 MMSC on 3G only no MMSC on LTE

Screenshot_20181001-155723.pngScreenshot_20181001-155731.pngScreenshot_20181001-155747.png

 

As you can see by the screen shots if I want to receive picture messages I have to choose the 3G APN

I can select lte and get 4G but then MMSC doesn't work.

 

Why has Android blocked the ability to update APN settings?

 

FIDO update the APN settings so we can use MMSC on our Android 8.1 devices with 4G/LTE!

Google/Android blocking this feature of editing APN is something Apple would do (after being a long time frustrated iPhone user I am very dissapointed to come across this option blocked...)

Accepted Solution

Re: APN Settings Need Update Android 8.1 MMSC on 3G only no MMSC on LTE

Solved by MVP MVP

Hello @dGio,

 

Did you try taking the SIM out of the phone and see if it will allow you to edit the APN?

 

I personally experience this issue with a few phones where it was not letting me edit the APN what I did was tap on the burger menu (the 3 dots) hit save went back out then tap on the APN again and I was able to edit it now. 

 

A few times I have to do a network reset first then reboot and did the same steps above in order to edit the APN.

View solution in context
32 REPLIES 32
patrickchan
I'm Experienced Level 1

hi

i would get new sim, and make sure to get assistance from fido sales people to confirm apn settings, you should be good to go.

i had to get new sim card for my s9+ to get the wifi calling / voiceLTE to work , with the apn settings confirmation as well from the nice staff at Fido store in west edmonton mall.

FidoKenny
Moderator

@Cawtau 


Hey Smiley You think you can help out with this?



Cawtau
Senior MVP

Hello dGio,

 

  Welcome to the community!

 

  Hmm, that's strange. The ltemobile.apn should have the proper settings for MMS. Are you able to delete the fido internet (ltemobile.apn) from your phone. If possible, you should be able to create a new ltemobile.apn using the settings here.

 

  Do you have a older SIM? It used to be that Fido phones used two APNs: one for internet - fido-core-appl1.apn, and the other for MMS - mms.fido.ca. However, most phones can now manage to use a single APN for both internet and MMS (specified in APN Type).

 

  **edit** Where did you find the fido internet (ltemobile.apn) settings? Fido's ltemobile.apn does not require a username nor password.**

 

Hope this helps Smiley

 

Cheers


dGio
I'm a Contributor Level 1

Settings > Network & Internet > Mobile Network > Access Point Names

dGio
I'm a Contributor Level 1

Android Oreo 8.1 does not allow editing or creating APNs

 

The SIM is about 2 years old I believe.

Hello again,

 

  After a bit of Googling, it seems to be an added feature of Oreo (see here)? This forum thread provides a method solve the issue. However, if you are unfamiliar with debugging, you should do more research before attempting any such method.

 

  Alternatively, since your SIM is about 2 years old, you might consider trying a new SIM. A new SIM might be able to push the proper APN settings to your phone.

 

Hope this helps Smiley

 

Cheers


dGio
I'm a Contributor Level 1

Installed SDK, opened a command shell etc...

went to apn settings but still was unable to edit/create apn settings.IMG_20181002_164545_7[1].jpgScreenshot_20181002-164529[1].png

Hello again,

 

  Sorry to hear that command code trick did not work for you. I still think it's worth to try a new SIM. Even if this supposed new feature was added to Oreo, there has to be a way for different providers to add their APNs to the phone. Using a newer SIM might allow Fido to push the proper APN(s) to the phone.

 

Aside: How did you get those APNs on the phone? Did you enter them yourself or were they automatically entered for you? What phone do you have? Was MMS working properly using LTE before your phone updated to Oreo? I only ask because I don't remember seeing the fido-core-appl1.apn referred to as GPRS, nor do I remember a ltemobile.apn with username and password...

 

  If a new SIM does not help, the only thing I can think of would be to downgrade the OS and then add or edit the APN(s) as necessary. Re-installing Oreo should then keep the proper APNs. I understand this suggestion is not ideal. You might consider contacting Google to see if they have any suggestions (and to see if this feature can be removed in future versions).

 

Hope this helps Smiley

 

Cheers


Hello @dGio,

 

Did you try taking the SIM out of the phone and see if it will allow you to edit the APN?

 

I personally experience this issue with a few phones where it was not letting me edit the APN what I did was tap on the burger menu (the 3 dots) hit save went back out then tap on the APN again and I was able to edit it now. 

 

A few times I have to do a network reset first then reboot and did the same steps above in order to edit the APN.



dGio
I'm a Contributor Level 1

Oh and no I didn't take the sim out, I just went to settings for the APN and tripple clicked the 3 dots

dGio
I'm a Contributor Level 1

Wooooohoooo! Fixed!!Wooooohoooo! Fixed!!

Tapped the 3 dots at the top and it reset and now the lte has the proper MMSC listed!  Such an easy fix thank you so much.

 

I'm still really pissed at Google for blocking that feature in Android 8.1

They need to take it out. 

 

Hey @dGio,

 

I'm glad it worked for you, sometimes the simplest thing gets overlooked.



dGio
I'm a Contributor Level 1

My phone updated via FOR A today and the APN settings are fubard again.

 

I pulled the Sim, tried resetting it, tried restore to default (which worked last time) nothing helped.

 

The Fido MMS APN has the correct settings for MMSC but I can't select it.

 

As you can see my list of APN has changed, were does this come from and how do I fix it? Is this a problem with my new firmware or an old Sim or what? Pressing the three dots and reset to default fixed it last time but not now....

 

Screenshot_20181026-164624.png

 

Screenshot_20181026-164636.png

 

Hey @dGio

 

I am sorry to see that you're having issues with the APN settings again! Since you've tried the steps again and nothing works, I'll send you a PM so we can take a loon into this together.

 

Chat soon Smiley



cbsewell
I'm a Contributor Level 2

I know this is an old thread, but the exact same thing happened on my phone.  The screenshots are identical and the problem is also identical: MMS only on 3G network, no way toadd or edit APNs. Only resetting the network didn't help for me, even temporarily.

 

Now I have a new phone and am stuck with the original APN screen. I suppose if I get an update, I'll get the new list of APNs, also wrong.

 

The APNs are provided by the phone manufacturer from a database of APNs, not pushed down by Fido. Your update from the phone manufacturer gave you an updated database, which was unfortunately still wrong.

brewmaster
I'm a Participant Level 3

I am haing the exact same issue. I cannot edit the APN settings on my new phone to get MMS working! Extremely frustrating. My settings look exactly the same as the image the OP put up. Is there a fix yet? Please Fido, don't leave this alone. There are many of us with the same issue. 

 

Kelvin

Hey there @brewmaster! I hope you're doing well. Smiley

 

Just to confirm, have you tried all the troubleshooting noted above?

 

Let us know.



brewmaster
I'm a Participant Level 3

I have tried all the troubleshooting. The only way to get MMS messaging working is to select 3G only. The APN settings are incorrect and are not editable. We NEED to change the APN settings in order to get it working or Fido needs to supply the correct settings via push.

Hey there @brewmaster!

 

Can you try to create a new APN with the following settings? Everything that I have left blank, you need to leave it to your phone's default.

 

Name: Fido 2
APN: internet.fido.ca
Proxy:
Port:
Username: fido
Password: fido
Server:
MMSC: http://mms.fido.ca
MMS proxy:
MMS port: 80
MCC: 302
MNC: 370
Authentication type: 
APN Type: default,supl,mms
APN protocol: IPv4
APN roaming protocol: IPv4
Bearer: Unspecified
APN PPP phone number: Not Set

 

Try that, restart your phone, and tell us if it did anything for you.

 

 

brewmaster
I'm a Participant Level 3


@FidoPhilP wrote:

Hey there @brewmaster!

 

Can you try to create a new APN with the following settings? Everything that I have left blank, you need to leave it to your phone's default.

 

 

 


LOL. Apparently you haven't read the entire thread. Or any of it. The point is that the apn settings are not editable and you cannot create a new one. With the Sim card removed the apn settings do not even show. With the Sim card inserted there in no option for a new apn. 

 

Kelvin