Fido App Data Usage Issue - Real-time Usage

Fido App Data Usage Issue - Real-time Usage

Fido App Data Usage Issue - Real-time Usage

I'm a Participant Level 2

Fido App Data Usage Issue - Real-time Usage

Hello Fido forum,

I just wanted to report some technical issues I've been experiencing to version of the Fido My Account. At first, real time data usage was being display but since last week, no more real time reporting.


More importantly, I often get the spinning loading icon when trying to view my usage and it keeps spinning forever. Other tabs like Phone and Plan within the Usage tab, Billing, etc work without issue -- only the "Usage" page within the Usage Tab fails to load.

See the screenshots below as proof.


Trust me, I've forced closed the app numerous times, rebooted my phone, and am very familiar with the Fido My Account app. 

These issues only started since last week on my phone and my wife's, too. Please fix these technical issues soon, thank you!



Hello @Alexandre9 and welcome to the Community. 

This is definitely not the experience we want you to have with the Fido App.


You had a chance to remove and reinstall the app to see if you get the same result?


Also, which phone model are you using right now?


Can you also confirm that the same thing happens when your WI-FI is ON or OFF?



I'm Qualified Level 3

@FidoKenny, thank you for your speedy reply. Yes, I have reinstalled the Fido App twice and still the data usage will differ at times. See the attached photo below where I compare my remaining data in the app vs I have an iPhone 8 running the latest iOS v12.3.1 and Fido app v4.0. I was connected to WIFI when the photo was taken. Problem occurs over cellular data as well. Issue started when new Fido app rolled out.


Fido App - Usage Not Accurate.JPG

Thanks for the additional details @nick67!


We've looked into it with our app team and they're fully aware. It should be corrected by the end of the week Smiley


@appledriver1 in terms of your post, we moved it here as the topics are similar. 


Can you let us know if your usage shows up on We're aware that this app version may have some inconsistencies with usage and we're working on it. If your usage shows up on then it's related, if it does not, we'll look into it further.



I'm a Participant Level 2

Yes I can see my data usage on Thanks for looking into it.

I'm a Participant Level 1

experiencing same thing they don't help so inconvinent to use this support system wasting time and energy and bad customer service terrible.😠

Hey @h9160422!


I've moved your post here as it's a more recent thread that relates to what you're experiencing.


Are you on app version 4.0 or 4.0.1?


If so, we're aware usage may not be showing and we're working on it! Your usage should show on in the meantime.


Hope that helps Smiley 

I'm Qualified Level 3

Update:  Usage is still not consistent after updating to Fido App v4.0.1


Currently, my Fido app says I have 3.62GB remaining data but says 3.56GB.

I understand this is a known issue and technicians are addressing.

Thanks @nick67!


Stay tuned for version 4.1 later this month Smiley



I'm Qualified Level 3

Thanks @FidoNick, appreciate the update! Hopefully Fido adds the "pull to refresh" feature too so I don't have to force close the My Account app to refresh the usage Smiley

I'm Qualified Level 3

Hello Fido team, I noticed even after updating to Fido app v 4.1.1, there is still a discrepancy between my Fido app usage vs. My Account usage. See the two screenshots below where I compare by data usage at the same time on the Fido app vs. My account on safari web browser. I've tried over cellular data as well and received the same result of differing usage numbers. Please have the technical department review, thanks Fido!


Fido AppFido My My Account

Hi @nick67


Thank you very much for bringing this to our attention. We are currently rolling out a new version of the app in batches and you should receive it shortly.


Could you confirm that you're still seeing the difference between the app and the web browser after you receive the new version? It should start by 4.2.


Please keep the Community posted. Smiley 



I'm Qualified Level 3

Hello @FidoFrancois , I have updated my Fido app to v4.2 and the data usage discrepancy still persists. My Fido app currently says 3.87GB remaining and on I get 3.84GB. It would appear the Fido app is not real-time and there is a lag. Thanks. 

Thanks for keeping us posted, @nick67.


I'll send you a PM to look into it with you as you shouldn't be experiencing this on the latest version.


Talk soon!



I'm a Participant Level 2



Fido App cannot show the data usage on my Android (9.0) phone. In USAGE tab, it always shows "Usage details not available. Sorry your usage details are not available. Please try again later." The "PHONE" and "PLAN" tabs seems ok.

I'm Qualified Level 3

I agree with @Alexandre9 that I can't tell if my data usage is real time or not. When I compare my data usage on versus the Fido app, sometimes the figures differ. I recently had the Fido App show 3.98 GB data remaining, then I reopened the app 2 hours later and it displayed 4.15GB remaining...somehow I gained back data?


Also, I would like Fido bring back the "pull down to refresh" feature. Currently, the only way to refresh my usage is to force close the app and relaunch it. If the app is idling in the background, opening the app will permanently show your usage when you first launched the app.