Showing results for 
Search instead for 
Did you mean: 

"failed to download attachment from multimedia" message

I'm a participant level 1
I'm a participant level 1

After misplacing and later finding my phone (Galaxy A8)--and having a new SIM installed--I cannot connect with the network from my home address. I get the above message when I turn the device on, and this when trying to connect through mobile network settings: "Error while searching for networks." I live in a rural area but never had issues in the 14 months before the new SIM card went in. After several trips to the store, replacement of the power switch, hours on-line with the Fido tech team, I am at a loss. Final recommendation was to try a different SIM card, but of course difficult to do with closures etc. now. The phone worked in the city but not out here. Is there something I can do myself to try a different SIM or must I wait till local Fido stores are open again? Appreciate any tips folks have. I've tried turning flight mode on and off, powering off and on again, etc.


Former Moderator
Former Moderator

Hey @pyrmomma


I'll send you a PM so that we can take a look at this with you.


Talk to you soon!