Where's the 2.2 froyo upgrade?

Where's the 2.2 froyo upgrade?

Where's the 2.2 froyo upgrade?

SOLVED
I'm a Participant Level 2

Where's the 2.2 froyo upgrade?

So I purchased an Acer Liquid E thinking it came with FroYo 2.2 only to find it needs a OS upgrade. Now where is the promised link? Fido dosnt have it. Acer dosnt have it. customer service on both sides keep telling me to call the other. I tried using the generic flash from Acer but this won't work with out some altering of the phone. All I need is the Fido version of this upgrade please help.

 

 

***Edited to add labels***

Accepted Solution

Re: Where's the 2.2 froyo upgrade?

Solved by Former Moderator FidoJudhy

Hello delta604,

 

Please note that there is currently an issue with Froyo where calls to 311 are incorrectly redirected to 911.

 

The links the the affected software have therefore been temporarily removed from both Fido.ca and Acer's websites.

 

They will be put back in place once the corrected Froyo software will be available.

 

We are working with the manufacturer to provide a software update to fix this issue as soon as possible.

View solution in context
7 REPLIES 7
I'm a Participant Level 2

I've been trying to update my liquid e with no accomplishment and tried again today and thought there was more action going on with my phone with the froyo update but now my phone won't turn on at all!!!  Very frustrated with all the attempts of upgrading and now I have a dead phone that won't even start up!!!!  Calling fido is useless because they sent me to acer support number which was completely useless as well as they refused to give me any type of help unless I was willing to pay for it.  One of the techs didn't even know that Acer made this type of product.  GRRR GRRRR GRRR!!!  I knew something was defective with my phone from the moment I bought it and fido keeps sending me in circles!!!!!  WTF!!!

 

MAD MAD MAD!!

I'm Qualified Level 1

You can try the Acer website: http://www.acer.ca/ac/en/CA/content/drivers

 

Just select Smartphone>Liquid>Liquid E

 

Then in the list there seems to be the update available for Fido. It's the middle file.

Former Moderator

Hello delta604,

 

Please note that there is currently an issue with Froyo where calls to 311 are incorrectly redirected to 911.

 

The links the the affected software have therefore been temporarily removed from both Fido.ca and Acer's websites.

 

They will be put back in place once the corrected Froyo software will be available.

 

We are working with the manufacturer to provide a software update to fix this issue as soon as possible.



I'm a Participant Level 1

I installed the fix for 311 / 911 issue and now have a GPS Test program not working. Any hints?

Hello rodb42,

Have you tried a battery pull?

@ Community: Has anyone else experienced this issue with the update? Were you able to find a fix?



I'm a Participant Level 1

Hi there !

 

How about this ?

 

I need to sync my Google Apps Calendar with my Liquid E (req by my job) and Old 2.1 seems to do it only for Classic Google Account, not Google Apps Accounts...

 

No sign of Froyo available on Liquid E though... What about it ?

Is it possible to have if I promise not to use 311 (Which I actually don't care about, thanks !) ?

 

Cordially,

Mathieu Lemoine.

Hello MLemoine,

 

I also have the Acer Liquid E on 2.1 and cannot wait for Froyo to be available once again.

 

Unfortunately, even with the promise not to use 311 (which I also do not use), the software was deleted from the servers and will not be restored on it prior to its issues being fixed.

 

I am sorry for the inconveniences caused by situation.

 

I would invite you to contact Acer to know when it will be once again available.