cancel
Showing results for 
Search instead for 
Did you mean: 

USA unlocked note 10+ 5g won't work on fido

Jsueu3jeus
I'm a Participant Level 2
I'm a Participant Level 2

Hello 

 

I bought an unlocked AT&T phone from eBay (from the USA) and everything on the phone works fine except that I can't make any calls or send texts. when I try to make a call I get the message :

' Your phones not registered on a network, so you can only make emergency calls. '

I have talked to Samsung customer service they said the imei is clear and that the phone is in fact unlocked.

I talked to fido representatives, they said they changed the tower signal or something and the phone worked for about 10 minutes (I was making and receiving calls) but then it went back to the way it was. Giving me errors and not making calls.

 

Anyone knows what is going on here? I guess I send the phone back in a week if I can't find a solution. 

3 REPLIES 3

Cawtau
Senior MVP Senior MVP
Senior MVP

Hello Jsueu3jeus,

 

  Welcome to the community!

 

  Firstly, had you previously been able to make/receive calls at your location using a different device? Also, you note you are not able to make calls, are you able to receive calls?

 

  As far as I am aware, these are the specifications for that phone:

4G LTE Bands 1, 2, 3, 4, 5, 7, 8, 12, 14, 18, 19, 20, 28, 29, 30, 38, 39, 40, 41, 46 and 66
4G HSPA+ with enhanced backhaul
3G - UMTS 850/900/1700/1900/2100MHz
GSM/GPRS/EDGE 850/900/1800/1900MHz

~taken from here.

 

  According to those specifications, the phone should have most of the compatible bands/frequencies. You can verify the compatible bands/frequencies here.

 

  If it's your first time using services on the Fido/Rogers networks, it's possible your area isn't adequately covered. You can get an idea of your area cellular towers here.

 

  While it doesn't usually affect calling, have you verified it is using the proper APN? You can verify those settings here.

 

  Have you tried to disable the HD voice or voice-over-LTE (voLTE) setting on the device? Since the device is not a Canadian version, it's possible certain features (ie voLTE and/or Wifi-calling) might not work. If that is the case, your phone would need to fall-back to the '3G' or 2G networks for calls. Your phone might be adequately connecting to LTE networks for data, but unable to adequately receive '3G' or 2G signals for calls.

 

  Personally, I would tend to stay away from devices from the US. Those mobile providers have been notorious for making things difficult to use their devices on different networks. In Canada, there tends to be one version of a device used by all of the different providers. However, many US providers have their own versions of the same device. They have often placed limitations or annoyances on their own versions if used on other networks.

 

  I understand Canadian versions might not necessarily have all of the features available in devices from other regions. A global version device would be less likely have any restrictions placed compared to their US counterparts. However, since the device is not a Canadian version, it would still unlikely work for features like voLTE or Wifi-calling.

 

Hope this helps 😀

 

Cheers


Jsueu3jeus
I'm a Participant Level 2
I'm a Participant Level 2

Thanks for the reply 

 

How do I disable the  HD voice or voice-over-LTE (voLTE)? So that my phone goes back to 2G / 3G networks? 

Hello again,

 

  After some research, I'm not sure whether that version is actually capable of HD or voLTE calling out of the box. According to this source, that phone might need a software update in order to enable the feature. However, it's also possible that the update is only required for use on the AT&T networks. If your phone is already capable of the feature, the setting might be under the Phone settings or Mobile Networks (see here). I didn't happen to see the feature in the User Manual, though, which might support the notion that an update might be required. You should note that any updates would not be available from Fido.

 

  You might consider testing whether your issue relates to HD or voLTE calling by manually disabling LTE (ie selecting Network mode as '3G'/2G only). If your issue disappears, then it's likely related to that feature or your phone switching networks. On the other hand, if your issue persists, it's possible your area is not adequately covered. Are you able to make/receive calls from other areas? Unfortunately, there appear to be few cellular towers in your area (I'll rely to your other post shortly).

 

Hope this helps 😀

 

Cheers