Showing results for 
Search instead for 
Did you mean: 


I'm a participant level 1
I'm a participant level 1

Hi just buy a unlocked LG V20.  When I insert the FIDO sim card I get this following message "SIM CARD IS NOT FROM VERIZON WIRELESS".  The phone does not ask for SIM Network unlock PIN, then it is not locked.


What should I do for the phone to be able to use my sim card?


Thank you


Senior MVP Senior MVP
Senior MVP

Hello Gbeauliere,


  Welcome to the community!


  Firstly, according the band/frequency specifications listed on the LG website, these are the specifications for that phone:


1.9 GHz CDMA PCS, 800 MHz CDMA; GSM 850/900/1800/1900 MHz; UMTS 850/900/1900/2100 MHz; LTE Bands 2/3/4/5/7/13/20/66* and CA


  According to those specifications, that phone would have all of the compatible bands/frequencies for 2G and '3G'. With regards to LTE, that phone only has two compatible bands/frequencies. You can verify the compatible bands/frequencies here. While the phone should work on the networks, coverage with LTE would depend on the bands/frequencies used at your local cellular towers. You can get an idea of your local cellular towers here.


  You should also note that certain features (ie Wifi-calling and/or voLTE) won't likely work with that phone as they would not be supported on the Verizon version of the device.


  Since the phone is not from Fido, have you verified it's using the proper APN? Since the phone is LTE-capable, it should be using ltemobile.apn. You can verify those settings here.


  I understand you receive that message, however, are you able to use your services (ie Talk, text, or data) with that phone? At least with Samsung, that message is due to an app which is a part of the phone's firmware. Apparently the phone should still work with non-Verizon SIMs. There may be a way to permanently remove the notification if you root the phone, but to temporarily remove it you can try:


Go to settings >> applications >> application manager >> all
Then find an application called "activation agent".
Click on it, then click force stop.


 This video shows a different method of temporarily removing the notification.


 However, I believe the notification will reappear after a reboot. 


Hope this helps 😀