Nokia N95 MMS not working

Reply
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Nokia N95 MMS not working

It has been about 2 years i have this phone and after many calls and looking up information online for the MMS setting nobody has been able to help me. I find this very ODD as FIDO is a service provider and not a hardware provider. Setting up an MMS capable piece of hardware on their network should be a easy. Apparently nobody at fido has the settings and use the excuse that it is not a fido phone that is why it does not work. FYI!!! THERE IS NO SUCH THING AS A FIDO PHONE. Any help would be greatly appreciated.

 

 

***Edited to add labels***

Accepted Solution

Re: Nokia N95 MMS not working

Hi N95_user

 

You need a data plan for MMS to work on the N95.

 

Here are the MMS settings:

 

http://forums.fido.ca/t5/forums/forumtopicpage/board-id/mobile_internet/message-id/75/highlight/true#M75

 

 

View solution in context
Flag this to a Moderator
Message 1 of 4
3,596 Views
Highlighted
Former Moderator
Former Moderator
Solution

Re: Nokia N95 MMS not working

Hi N95_user

 

You need a data plan for MMS to work on the N95.

 

Here are the MMS settings:

 

http://forums.fido.ca/t5/forums/forumtopicpage/board-id/mobile_internet/message-id/75/highlight/true...

 

 



Flag this to a Moderator
Message 2 of 4
3,583 Views
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Re: Nokia N95 MMS not working

Thanks for the reply. I do have a data plan and those settings in my phone. I have the same problems as the reply to that link.  Thanks anyways.

Flag this to a Moderator
Message 3 of 4
3,545 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: Nokia N95 MMS not working

Have you set or changed the multimedia retrieval setting?
Non-fido phones are roaming, so certain phone dependant settings that are set to -in home network must be changed..(handset specific)

Messaging / Options / Settings / Multimedia Message / Multimedia Retrieval

- Multimedia Retrieval: Select the way you want to receive multimedia messages.
-Select Always automatic to access multimedia messages automatically.

Be sure to click Likes for those who have helped you!
Click Accept as a Solution for posts that have solved your issue(s).
Flag this to a Moderator
Message 4 of 4
3,523 Views