Showing results for 
Search instead for 
Did you mean: 

No service after porting my number from Bell to Fido

I'm a participant level 1
I'm a participant level 1

I got my new Fido SIM card today and it worked well with the temporary number. However, after I ported my old number from Bell to Fido, there has been no service (data, call, text) and it has been 6 hours. The status of my number transfer request is completed. I tried restarting my phone and resetting all network several times but still not working. I tried to reach out to tech support and was put on hold forever. I've transfered the number several times before and this is the first time I came across this situation. I'm getting very frustrated now. Can anyone please HELP????? @livetechsupport 



Hello @Shannonmmmm,


Welcome to the community!


Sorry to hear that the porting process did not go as intended, you should note that this community forum is driven by customers like myself to help each other, and it is not a venue for customer support for Fido.


In this case, since access to your account would be needed you will have to reach out to customer/tech support through any of the available methods listed here.