Huawei mate 20 pro could not send message after emui 10 upgrade

Reply
I'm a Contributor Level 1 justinren
I'm a Contributor Level 1

Huawei mate 20 pro could not send message after emui 10 upgrade

I just upgraded my mate 20 pro to emui 10 through the official update from the phone itself. Before the update, everything is functioning well. After the update, I am not able to send text message to any iphone users, but somehow I can send picture message to them. I am not able to send text message to android users sometimes as well, but 80% of time I can send message successfully to android users. Any thought how to solve this? I am using the default messages app only

Accepted Solution

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hey @justinren, try clearing the text app cache that you are using if the problem is still there then a factory reset might have to be done. I always recommend a factory reset after any major updates to avoid any issues.

View solution in context
Flag this to a Moderator
Message 1 of 15
449 Views
Highlighted

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hello @justinren,

 

Try wiping the cache partition, you can follow the instructions here.



Flag this to a Moderator
Message 2 of 15
300 Views
Highlighted
I'm a Contributor Level 1 justinren
I'm a Contributor Level 1

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hello @KAPABLE-K, thanks for helping out.  just tried it, still not working.

Flag this to a Moderator
Message 3 of 15
291 Views
Highlighted
Solution

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hey @justinren, try clearing the text app cache that you are using if the problem is still there then a factory reset might have to be done. I always recommend a factory reset after any major updates to avoid any issues.



Flag this to a Moderator
Message 4 of 15
276 Views
Highlighted
I'm a Contributor Level 1 justinren
I'm a Contributor Level 1

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Thanks @KAPABLE-K . Factory reset did solve the problem, although I have to say I hate all the hassle I have to do with all my apps and settings, but I guess thats the only way. Thank you

Flag this to a Moderator
Message 5 of 15
246 Views
Highlighted

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hey @justinren

 

Factory resetting is never fun but I'm happy you got it working, enjoy!



Flag this to a Moderator
Message 6 of 15
228 Views
Highlighted
I'm a Contributor Level 1 justinren
I'm a Contributor Level 1

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Update: unfortunately it only worked for 1 day, now I cant send message again. I do not want to factory reset again

Flag this to a Moderator
Message 7 of 15
202 Views
Highlighted

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Hey @justinren,

 

It sounds like you have an app that is causing your problem. Do you have any antivirus apps installed? 

 

Try booting into safe mode and send yourself a text if it works then you will know it's an app causing the problem. You will have to uninstall apps one at a time to try to figure out which one is causing the problem.

 

  1. Power off the device
  2. Power it back on
  3. When you see the Huawei animation on the screen press and hold volume down button
  4. You will see safe mode at the bottom left corner once the device finishes booting


Flag this to a Moderator
Message 8 of 15
197 Views
Highlighted
I'm a Contributor Level 1 justinren
I'm a Contributor Level 1

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Cant even send it in safe mode, even to myself

Flag this to a Moderator
Message 9 of 15
194 Views
Highlighted

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

@justinren do you have access to another phone that you can put the SIM card in to test? 



Flag this to a Moderator
Message 10 of 15
192 Views