Showing results for 
Search instead for 
Did you mean: 

[Huawei P30] Did firmware break Wifi Calling?

I'm a contributor level 1
I'm a contributor level 1

After upgrading my firmware from 138 to 156 Wifi calling has stopped working for me.  It now returns "Registration timed out" now if I try to disable and re-enable it.


Tried to re-register the device, still no luck.


Is this a known issue with firmware 156?


Not really a deal breaker for me since I get a good enough LTE signal at home, just curious.


Former Moderator
Former Moderator

Hey there @PB


There would be a couple of details we'd need to inquire about to better assist you. Would you be able to provide us with the following:


  1. Are you getting an error message when setting it up or is it simply not working with no error messages?
  2. If there's an error message, what's the content?
  3. Did you recently port in your number?

Let us know so we can take a closer look, and don't hesitate to reach out to us here as well for further assistance Smiley

I'm a contributor level 1
I'm a contributor level 1

The Wifi calling icon stopped showing up in the notification area, indicating that the phone is using VoLTE instead (the HD icon is there indicating VoLTE).


When I disable and re-enable Wifi Calling, it shows the error message I wrote in my first post.


Phone number has been with Fido for at least two years, and was working fine with Wifi Calling when I enabled it two months ago.  It only stopped working at about the same time I upgraded the phone firmware to build 156, about a week or two ago.


Phone was bought from Fido.  I strongly suspect that Wifi Calling was broken either by the new firmware, or by a Google Play update that would have occurred at around the same time (I didn't notice the exact moment the Wifi Calling icon disappeared).


Former Moderator
Former Moderator

Hey @PB


We were unable to reproduce this on our end which leads us to believe that it might be a Wi-Fi connectivity issue. A few recommendations:

  1. Check the access point used for any connectivity issues (update the software, check firewalls…). One example of such access points blocking Wi-Fi Calling is the public TCONNECT in TTC; people have seen similar timeout errors when trying to get Wi-Fi Calling work over it.
  2. Try other access points.

Let us know if anything Smiley

I'm a contributor level 1
I'm a contributor level 1

I finally took the time to do a complete factory default reset of my phone, which resolved the issue.  I can only assume that when firmware was installed, the Wifi Calling parameters got somehow corrupted, and just disabling/re-enabling it wasn't sufficient to resolve it.


I have seen other users report similar issues with either VoLTE or Wifi Calling when upgrading their P30 or P30 Pro, with various providers (not just Fido).  I assume it's a bug in the firmware upgrade process.


Thanks for the update @PB!


We all appreciate it. Smiley