Disable Text Message for New Voicemail

Disable Text Message for New Voicemail

Disable Text Message for New Voicemail

SOLVED
FolkSong
I'm a Contributor Level 1

Disable Text Message for New Voicemail

I just got a Pixel 4A and I noticed that when I get a voicemail, it gives me a notification through the phone app. But then i also get the old notification via text message, so it's a bit annoying having to clear both notifications. Is there a way to disable the text messages since they don't seem to be needed anymore?

Accepted Solution

Re: Disable Text Message for New Voicemail

Solved by Senior MVP Senior MVP

Hello FolkSong,

 

  I understand you might find the app notification more useful, however, I'm not sure disabling the text notification will accomplish what you hope. For mobile phones, the message-waiting indicator (MWI) is sent via SMS (see here). If Fido were to disable the text notifications, the message-waiting indicator on your phone would not function either.

 

  I think the issue stems from how the phones deal with the voicemail text message. Fido is not sending two notifications (ie one text message and one MWI), it is the same SMS. It used to be that those text messages were hidden and only triggered a phone's MWI. However, with some phones, that message will trigger the MWI while other phones receive the notification as a text message (not hidden anymore). Apparently, your phone both triggers the MWI as well as receives the text message.

 

  Do you have the basic voicemail or the Premium Voicemail?

 

Hope this helps 😀

 

Cheers

 

View solution in context
4 REPLIES 4
FolkSong
I'm a Contributor Level 1

Hi Kenny thanks for the reply. I could do that, but it's going in the wrong direction. I like the app notification, the text message is what I want to turn off.

 

The app notification is much more functional than the text message. For example, I can tap on the app notification and it instantly dials into voicemail. With text messages I have to manually delete them, or else they clutter up my inbox, and then manually open the phone app and call voicemail. Not very convenient.

 

I take it Fido doesn't provide a way to turn off text message voicemail notifications?

Hello FolkSong,

 

  I understand you might find the app notification more useful, however, I'm not sure disabling the text notification will accomplish what you hope. For mobile phones, the message-waiting indicator (MWI) is sent via SMS (see here). If Fido were to disable the text notifications, the message-waiting indicator on your phone would not function either.

 

  I think the issue stems from how the phones deal with the voicemail text message. Fido is not sending two notifications (ie one text message and one MWI), it is the same SMS. It used to be that those text messages were hidden and only triggered a phone's MWI. However, with some phones, that message will trigger the MWI while other phones receive the notification as a text message (not hidden anymore). Apparently, your phone both triggers the MWI as well as receives the text message.

 

  Do you have the basic voicemail or the Premium Voicemail?

 

Hope this helps 😀

 

Cheers

 


FolkSong
I'm a Contributor Level 1

Thanks very much Cawtau, I really appreciate the technical explanation. I wasn't aware of how the MWI worked. I will dig around to see if anything can be done on the phone to hide the text message. I just have the basic voicemail.

FidoKenny
Moderator

Hey @FolkSong

 

I checked quickly no my end and you can manage the setting of your Pixel 4 when it comes to the notifcations.

 

You could close the notifications of your voicemail app.

 

Here is what I found online: 

 

Open your phone's Settings app.


Tap Apps & notifications. Notifications.


Under "Recently Sent," tap an app.


Tap a type of notification.


Choose your options: Default: Your phone will ring or vibrate, which depends on your settings.

 

 

Let me know how it goes on your end.