Device lost in transit

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Device lost in transit

Hi,

 

Its been 15 days since the failed attmept of a device that I ordered over the phone. Looks like the freight carrier UPS lost it. Now, UPS says ask Rogers (Fido) to ask for an investifgation for the phone. One the other hand Fido Answers is unable to Answer. Meanwhile my bill will get generated iwithin a week. Now if start getting billed for it.

 

Should I pay for a service / product that did not recieve ?

 

Can some one help answer ? 

 

Please help !!

bhvn

 

 **Edited to add tags and labels**

 

 

 

 

Flag this to a Moderator
Message 1 of 5
1,351 Views
Highlighted
Moderator
Moderator

Re: Device lost in transit

Hey @bhvn

 

Welcome to the community! Smiley

 

This definitely sounds like an unusual situation and I'd like to take a closer look into this with you.

 

I'll send you a PM so we can check it out!

 

 



Flag this to a Moderator
Message 2 of 5
1,346 Views
Highlighted
Moderator
Moderator

Re: Device lost in transit

Hey @bhvn!

 

Let us know how this was resolved! I'm sure the info can help others Smiley

 

 



Flag this to a Moderator
Message 3 of 5
1,285 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: Device lost in transit

Hey @Nick,

UPS has started the investigation. It seems they would share the progress only with Rogers so wouldn't have the updates. Would have been great if it could have been resolved before my bill gets generated.

Keeping my fingers crossed!!'
Flag this to a Moderator
Message 4 of 5
1,258 Views
Highlighted
Moderator
Moderator

Re: Device lost in transit

Hey @bhvn

 

Thank you for sharing this with us. Keep us posted! 

 

 



Flag this to a Moderator
Message 5 of 5
1,255 Views