Showing results for 
Search instead for 
Did you mean: 

Video calling for BYOD

I'm a participant level 3
I'm a participant level 3



I recently purchased a Google Pixel 3 direct from Google. I was able to enable VOLTE for voice calls but can not seem to enable the VOLTE video calling feature. I talked to Fido customer support and confirmed that my account is setup for video calling. How do I enable on my device?




I'm a participant level 3
I'm a participant level 3

Hi @FidoSaira,


Thanks for getting back to me. Regarding plan I'm currently on the Fido Pulse 10GB - BYOP plan.

As for the settings option to enable video calling that is not available on my device. I checked in device settings and the phone app settings. From what I understand it should be in the same menu as the wifi calling (which I do have access to).

When I go through the phone app and dial *#*#4636#*#* to access phone menu I see that "Wi-Fi Calling provisioned" can be toggled on or off. However, the "Video Calling provisioned" option is greyed out and in the off position and can not be toggled on.


Let me know if you have any further questions.




Former Moderator
Former Moderator

Thanks for confirming @8563049!


Looks like you've checked everything on your end. We'll have to access your account on our end to make sure that the video calling features is active and troubleshoot further.


I'm sending you a private message so we can do that. See you there Very_Happy


Hey @8563049,


Thanks for the details. 


I understand you have a BYOD, but can you clarify which plan you are currently on?


You should be able to see how to enable video calling in your user's manual guide. As per what I've found on my side, you can activate video calling on your Google Pixel 3 through your device's Settings > Calls > Turn on video calling switch.


Keep in mind that for video calling to work, the person you are calling needs to have a VoLTE compatible phone and service as well. 


Let us know how it goes!