Roaming

Roaming

Roaming

I'm a Participant Level 2

Roaming

I'm In Australia, have roaming on, flight mode off, wifi on

.  I'm trying to call a cell # in Australia but keep getting the message "Not registered on network". What do I need to do?

3 REPLIES 3
Moderator

Hey @RONG3,

 

Welcome to the community! 🙂

 

That's certainly not the experience we want you to have with Fido Roam and we realize how incredibly frustrating this must be.

 

Could you answer a few questions for us to have a better understanding of your situation?

 

- Did you have a chance to restart your phone to see if you get the same result?

- In the settings of your phone, do you have a network connection set to automatic or manual? Could you change it to manual? 

- Do you see other provider's networks? Have you tried different providers to see if you can roam afterwards? 

 

Let us know.



I'm a Participant Level 2

I did restart.

I did set it to manual.

I did get 4 other providers listed ad tried them all.  None worked.

Thanks for the update @RONG3.

 

 

Is it possible that you requested that roaming be blocked on your line in the past? If your device is able to find a network and won't connect,  restriction on roaming would explain that.

 

I'll send you a PM to check out your account. Talk soon!