Overcharges for roaming

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Overcharges for roaming

Seems yet again Fido, you’ve added international roaming to my bill when I clearly have not used your data by your own tracking system. It’s happened three months. 

 

This is becoming a trend. Every time I travel outside of Canada I am diligent about turning off cell data and then also setting my phone to airplane mode. I’ve learned that I should do this while still in Canada and rather not as soon as I land. Though I have not used data, I have been getting charged for it. I called the first time it happened and the bill corrected right away. I had to call the following month and it seems the charge is still on my bill - and now I’m being charged late fees. 

I’ve just received this month’s bill and yet again is has an error of a charge for roaming. 

 

There is a problem with your system. 

 

Before you add a charge to the bill, you should check usage first which may be a good way around fixing your roaming billing system. 

 

Kindly correct the last two bills and I’ll gladly pay for services rendered. 

 

Thank you 

Accepted Solution

Re: Overcharges for roaming

Hello AJ77,

 

  Welcome to the community!

 

  I understand how frustrating it is to be charged for something you did not think you used. However, I'm not sure the problem is with Fido's system. Airplane or Flight mode disables the phone's radios -- including the cellular radio. If your phone was set to Airplane mode before leaving Canada, it should not have been able to connect to any local networks. If your phone cannot connect to the local networks, Fido's system would not even know your phone was roaming.

 

  Are you getting charged for data or other services? Disabling data and/or roaming data does not prevent your phone from roaming for voice and text messaging. That said, Airplane mode should have also prevented usage of those services. What phone do you have? Is it capable of Wifi-calling? Is it possible you used some of your services via Wifi-calling?

 

  If you were charged for data usage with Airplane mode enabled, then that's an issue with your phone. It's connecting to networks when the cellular radios are supposed to be disabled. You might consider contacting the phone manufacturer to see if it's a known issue or if there is a fix.

 

Hope this helps 😀

 

Cheers

 

View solution in context
Flag this to a Moderator
Message 1 of 3
287 Views
Highlighted
Moderator
Moderator

Re: Overcharges for roaming

Hey @AJ77

 

I'm sad to learn that you have unexpected roaming charges.  Roaming charges can be caused by other usage than data.  Answering or placing a phone call or sending a text message would cause you to have roaming charges on your bill.

 

If you want more details about the bill, you can contact us using any of the options you'll find here.  Alternatively, we can send you a PM.



Flag this to a Moderator
Message 2 of 3
270 Views
Highlighted
Senior MVP Senior MVP
Senior MVP
Solution

Re: Overcharges for roaming

Hello AJ77,

 

  Welcome to the community!

 

  I understand how frustrating it is to be charged for something you did not think you used. However, I'm not sure the problem is with Fido's system. Airplane or Flight mode disables the phone's radios -- including the cellular radio. If your phone was set to Airplane mode before leaving Canada, it should not have been able to connect to any local networks. If your phone cannot connect to the local networks, Fido's system would not even know your phone was roaming.

 

  Are you getting charged for data or other services? Disabling data and/or roaming data does not prevent your phone from roaming for voice and text messaging. That said, Airplane mode should have also prevented usage of those services. What phone do you have? Is it capable of Wifi-calling? Is it possible you used some of your services via Wifi-calling?

 

  If you were charged for data usage with Airplane mode enabled, then that's an issue with your phone. It's connecting to networks when the cellular radios are supposed to be disabled. You might consider contacting the phone manufacturer to see if it's a known issue or if there is a fix.

 

Hope this helps 😀

 

Cheers

 


Flag this to a Moderator
Message 3 of 3
246 Views