Showing results for 
Search instead for 
Did you mean: 

Not able to send or receive MMS with WiFi enabled since the outage

I'm a participant level 1
I'm a participant level 1

Since the outage i have not been able to receive or send MMS messages on my Android phone.  I have tried doing some troubleshooting and have found that if I disable Wifi then I am able to send and receive MMS (pictures).  Once I enable wiFi and try to send an MMS it just sits and says sending.  Same if someone tries to send me an picture through text message it shows a little downloading icon which just spins till eventually it times out and then I can click on it to try to download it again, but it just fails so long as WiFi is enabled.  This worked perfectly fine before the outage so it has to be related.  Nothing else has changed (same Wifi, same phone, etc).  What else might be causing it?


Senior MVP Senior MVP
Senior MVP

Hello Jane828,


  Welcome to the community!


  Sorry to hear you're having issues with MMS messaging. I'm not sure whether it's related to the outage, though.


  I understand you don't think anything has changes. However, is it possible your device received an update?


  Multimedia-messaging services (MMS) messages require data to be enabled. With the exception of Wifi-calling, the data within MMS does not get transmitted via Wifi. Previously, android devices were able to send/receive MMS over a data connection when Wifi was enabled. However, Android now seems to disable data access when Wifi is enabled, preventing MMS. They added a setting Send & Receive when mobile data is off (see here). To be clear, that setting doesn't mean that MMS gets sent via Wifi or that data is not required. That setting allows MMS to use data even when Wifi disables data. It will enable data to send/receive MMS and then disable data. Unfortunately, as noted in that link, I am not able to find where that setting is located anymore. However, here is a video on how to find that setting. Full disclaimer: I have not used that app stated in the video. The setting appeared following an update.


Hope this helps 😀