No data plan, can't use WiFi like I was told I could

Reply
I'm a Participant Level 1 progpunk76
I'm a Participant Level 1

No data plan, can't use WiFi like I was told I could

Just re-upped my subscription for two more years, Kept old plan with no data. Got a Samsung Galaxy Ace II x and was told i could use WiFi. Everytime I connect fido won't let me connect to the internet and says I need a data plan. Did I get told wrong info or can i fix this problem. I am new to smart phones by the way. Thanks for any help that can be given.

 

 

***Edited to add labels***

Accepted Solution

Re: No data plan, can't use WiFi like I was told I could

By default, your phone will try to connect to the internet via a data connection. If you try to access the internet without a data addon, you will get that message from Fido to choose a data package. According to Fido.ca, the Ace II is indeed equip with WIFI. You must successfully connect to a WIFI network first, then attempt to use the internet or you will continue to get that pop-up from Fido. Go into your settings and try to connect to wifi first. Hope this helps friend Smiley

View solution in context
Flag this to a Moderator
Message 1 of 3
2,478 Views
Highlighted
I'm Qualified Level 3
I'm Qualified Level 3
Solution

Re: No data plan, can't use WiFi like I was told I could

By default, your phone will try to connect to the internet via a data connection. If you try to access the internet without a data addon, you will get that message from Fido to choose a data package. According to Fido.ca, the Ace II is indeed equip with WIFI. You must successfully connect to a WIFI network first, then attempt to use the internet or you will continue to get that pop-up from Fido. Go into your settings and try to connect to wifi first. Hope this helps friend Smiley

Flag this to a Moderator
Message 2 of 3
2,472 Views
Community Specialist
Community Specialist

Re: No data plan, can't use WiFi like I was told I could

You can also disable mobile data in your phone settings so that you'll only have access to Wi-Fi. This would prevent the message from being sent when you're not connected to a Wi-Fi network.

 

It would be in settings > wireless & networks  - more > mobile networks > mobile data. 



Flag this to a Moderator
Message 3 of 3
2,369 Views