cancel
Showing results for 
Search instead for 
Did you mean: 

New phone, data not working

dontwannareg
I'm a Participant Level 1
I'm a Participant Level 1

Hello,

 

I just got my s20 in the mail. It sycned with my old s8 just great. Wifi works great.

 

But when I leave the house and it switches to data it says no internet connection.

 

Ive updated the SIM card on the website as per the guide. Any ideas?

2 REPLIES 2

Cawtau
Senior MVP Senior MVP
Senior MVP

Hello Dontwannareg,

 

  Welcome to the community!

 

  Sorry to hear you're having issues with using your data. In addition to what has already been mentioned, have you verified that your phone is using the proper APN settings? You can verify those settings here. Since the device is LTE-capable, it should be using ltemobile.apn.

 

Hope this helps 😀

 

Cheers

 


Good morning @dontwannareg , welcome to the community. Did you try all the recommended troubleshooting methods? Does the fido network show up in the top settings bar where it shows the signal strength? Does the voice and text work?  Restart the phone, remove Sim and restart again. Then put the Sim back in to register with the network. Make sure you have mobile data turned  on in your settings. I know these may be obvious questions but that's what I check for when I troubleshoot. If all that doesn't help, you made need a network reset. You can find that in settings, general settings and reset, reset network. 

When all else fails,  call *611 for tech support. Have a good day and hope you get to enjoy the new phone.