Never able to upgrade plan or purchase phones online

Never able to upgrade plan or purchase phones online

Never able to upgrade plan or purchase phones online

I'm a Participant Level 2
I'm a Participant Level 2

Never able to upgrade plan or purchase phones online

This has been a reoccuring problem for my account for several years. I have tried to talk to reps on the phone and via the live chat and the problem has never been resolved, I've always just resigned to upgrading and purchasing the phones via phone, and eating the activation charge, and often settling for a worse plan as the reps say they cannot see the special offers being offered for the lines on the website. This is my last-ditch attempt to find a solution.

 

Every time I've gone to upgrade a phone for one of the lines on my plan, I get the "We're sorry, this information is currently not available online. If you need help with your account, please call 1-888-481-FIDO (3436)" error message. This happens at the exact same time in the process every time, having selected the phone, plan and add-ons and attempting to move on to the shipping address portion. I call the number and as said before, just end up going through the rep to complete the purchase rather than actually resolving the problem.

 

I have tried using different browsers, using different computers, trying it on my phone via different browsers or the Fido app, and it still happens every time. At first I thought it was because our account was very old and for a long time had very old grandfathered plans on most of the lines, but at this point every line is on a plan that is at most a few years old.

 

From browsing the forums I see that others have had this problem, but there's no indication of how to resolve, or if it ever has been. Holding out hope that there is a solution out there.

5 REPLIES 5
Moderator

Hey @AVM

 

It seems like you tried quite a few things on your side already.

 

Can you please let us know:

 

1. If the account is a regular consumer account or a business account?

2. If you are logging in with a subscriber profile or account holder profile?

 

Keep us posted. 

 

 

 



I'm a Participant Level 2
I'm a Participant Level 2

Hi @FidoClaudia thanks for your reply.

 

1. It is a business account, though it is extremely old (I believe it was first opened in 1997, maybe?) so it may be classified as something different in the system. But pretty sure it's a business account.

 

2. I'm logging in and attempting to make the upgrade/purchases using the subscriber profile

Hey @AVM

 

Let's verify your account together to see what's going on.

 

I'm sending you a PM. Talk to you soon.



Senior MVP

Hello AVM,

 

  Welcome to the community!

 

  Sorry to hear you've been having issues upgrading online.

 


@AVM wrote:.. but at this point every line is on a plan that is at most a few years old....

  If your plans are all a few years old, it's likely your agreements were with subsidised plans. Subsidised plans incorporated the cost of the devices into the cost of the plans. You should note that Fido has now switched from their subidised plans to a financed payment program for new devices. That is, the cost of devices is now separate from the cost of services. It's possible your old plan(s) is/are not compatible with the new financed model. If that is the case, you would need to switch to a new plan in order to finance a new phone. On the other hand, you would be able to keep your current plan if you purchased your new phone outright.

 

  I'm not sure if the system will process the switch properly. In some instances, the system was still offering subsidised options for customers with existing subsidised plans. That could be the reason you've received that error. If you would like to switch to a plan with the new financing model, you might need to contact customer service.  Alternatively, you might consider sending @FidoSolutions a PM. Once they verify some information, they'll also be able to access your account.

 

Hope this helps 😀

 

Cheers

 


I'm a Participant Level 2
I'm a Participant Level 2

Thanks for your reply. I did notice the new payment program. This issue originated long before that switch, it has happened every time I've tried to upgrade a phone and plan for the past five years.

 

As far as I can tell the plans I'm being offered on the line I am trying to upgrade use the new financed payment program, or at least it appears that way when I look at the breakdown/details before attempting to proceed.

 

Contacting customer service has always resulted in just purchasing the phone and upgrading the plan via a rep. I'm hoping to resolve the actual problem.