My sms is not working

My sms is not working

My sms is not working

SOLVED
Michael1313
I'm a Participant Level 1

My sms is not working

So I got the new I phone today and I have switched from bell to Fido . I can't receive any texts though. Apple support says to contact Fido but Fido's customer support is now closed. 
I can receive calls and I can send texts , but I don't receive the texts. The texts are still going to my old android phone. I have tried to turn off the setting to receive messages on my android but nothing seems to be working. 

Accepted Solution

Re: My sms is not working

Solved by Senior MVP Senior MVP

Hello Michael1313,

 

  Welcome to the community!

 

  If the text messages are still going to your old android phone, it sounds like your android phone might have been sending the messages as rich communication services (RCS) messages. Those messages are sent as data and can be transmitted via Wifi (similar to iMessages, though not compatible). That could be why your old android phone is still receiving those messages while your SIM is in your new phone. You might need to de-register your phone number from RCS (see here, here, and here). I understand you might have already tried to turn off the setting. Apparently, it may take up to 8 days?? to disable (see here).

 

Hope this helps 😀

 

Cheers

 

 

View solution in context
1 REPLY 1
Cawtau
Senior MVP

Hello Michael1313,

 

  Welcome to the community!

 

  If the text messages are still going to your old android phone, it sounds like your android phone might have been sending the messages as rich communication services (RCS) messages. Those messages are sent as data and can be transmitted via Wifi (similar to iMessages, though not compatible). That could be why your old android phone is still receiving those messages while your SIM is in your new phone. You might need to de-register your phone number from RCS (see here, here, and here). I understand you might have already tried to turn off the setting. Apparently, it may take up to 8 days?? to disable (see here).

 

Hope this helps 😀

 

Cheers