cancel
Showing results for 
Search instead for 
Did you mean: 

Have data but not working

Chey2
I'm a Participant Level 1
I'm a Participant Level 1

I have an iphone12 pro max and for some reason my data isn't working I'm not over my charges and there's no outings I have tried everything taking my SIM card out for 5 minutes with my phone off everything has anybody else had this problem what did you do to fix it 

4 REPLIES 4

asingh258
I'm a Participant Level 2
I'm a Participant Level 2

Its been a week now,

So far i have tried below on store and customer services recommendatio : 

reset phone

reset phone network

changed sim card

reset network from backend by support

 But no luck.

 

Store guys are not willing to help anymore, they even suggested to change carrier.

i need my data urgently in next 2 days n no ither option.

customer service always on hold, wasted already 8 hours on hold + lost arnd $1000 from my part time job due to no data.

 

Hey @asingh258, welcome to the community, Alex here! 

 

I'm sorry to see that you haven't been able to find a solution to this issue yet. 

 

I understand that you already reached out to our customer service, but they were not able to figure out what was causing this issue, so sorry about that! 

 

The next step would be to get in touch with our technical support team, they'll be able to further look into this with you. You'll simply need to call our customer service one more time and an agent will be able to transfer you. 



asingh258
I'm a Participant Level 2
I'm a Participant Level 2

I am having same issue, after upgrading plan, data not working at all.
store says eveyrhting looks good on our end, customer service says all good from their side, even reset network from back end but no luck.
phone is 100% fine,checked with other sim card.
sim card is working as well, as able to make and receive calls + send/receive text messages.

what to do next?should i change carrier?or

KAPABLE-K
MVP MVP
MVP

Hello @Chey2,

 

Welcome to the community!

 

Did you make any changes to your plan before this happened? If so it could be something was not applied properly and you would need to contact customer service directly and they will be able to assist you.

 

You can also try doing a network reset and see if that helps.