Fido Roaming not working in India

Fido Roaming not working in India

Fido Roaming not working in India

SOLVED
I'm a Participant Level 1

Fido Roaming not working in India

Hello,

 

I would like to bring to your notice that I am unable to use my current Fido SIM  while roaming in India. Since the day I landed (2nd March 2020), it never got the network; I had no choice to use a local SIM card in India to get going. It is almot 2 months I stuck here due to COVID 19 lock down and I need to check my calls and messages to catch up. Following are the steps I tried but with no success -

  • Use the SIM in different mob than my existing one; although my Indian SIM is working in my existing mob
  • Tried choosing all the network manully
  • Restart the network settings and even restart the mob several times
  • Set Cellular Data Option on

Nothing have worked and not sure what I am missing here. I have been paying my bill without using it. Any help will be appreciated! Thanks

Accepted Solution

Re: Fido Roaming not working in India

Solved by MVP MVP

Hello @AchintaSarkar,

 

Did you ever put any roaming block on your line? It sounds like there is a roaming block and that could be why you are experiencing that problem. 

 

You will have to reach out to customer service to have them look at your account to make sure no blocks are on it.

 

You can contact customer service even from outside of the country through any of the available methods listed here.

View solution in context
4 REPLIES 4

Hello @AchintaSarkar,

 

Did you ever put any roaming block on your line? It sounds like there is a roaming block and that could be why you are experiencing that problem. 

 

You will have to reach out to customer service to have them look at your account to make sure no blocks are on it.

 

You can contact customer service even from outside of the country through any of the available methods listed here.



I'm a Participant Level 2

What was the issue, I am also facing same issue, Network was coming properly through Idea network but all of sudden it's showing No service from last 2 days. 

Here you go for the details of my post. Need your help on this issue.

https://forums.fido.ca/t5/General-Support/Sim-showing-No-Service-in-INDIA/m-p/160451#M51967

I'm a Participant Level 1

If this issue was ever resolved, Can someone please post how as well. Had network for first week. Now nothing. I see Fido Available but with cross sign on network. Not able to manually register on any network as well.

Hello @vikas2910,

 

Welcome to the community!

 

Have you tried contacting us to troubleshoot this?

What has been tried up until now?

 

Let us know! 

 

-FidoAnthonyZ