Activated new Fido SIM online and it says ‘No Service’ on my phone.

Activated new Fido SIM online and it says ‘No Service’ on my phone.

Activated new Fido SIM online and it says ‘No Service’ on my phone.

I'm a Contributor Level 1

Activated new Fido SIM online and it says ‘No Service’ on my phone.

I successfully activated my new Fido SIM online, but when I put it in my new phone, it says 'No Service'. Now I'm stuck because my old SIM is inactive and my new one isn't working. I can't make or receive calls and mine is the only mobile phone in the house. Could someone please advise me what to do as I can't call Fido for help?

12 REPLIES 12

Hello @GG82,

 

Try restarting the phone again and even takeout the SIM card and put it back in and see if it helps. If you are still not able to get service you will have to reach out yo Fido either through live chat or on social media you can get that information here.



I'm a Contributor Level 1

Hi @KAPABLE-K,

 

Thanks for your feedback. I tried doing that a few times before I typed my post and it's still not working. I also did the same thing in an older iPhone and it eventually started working in that phone, so at least I can make and receive calls on one phone. I'm not sure why it's still not working on the iPhone I want to use.

 

Hey @GG82,

 

Were you able to get it working on the new iPhone?

 

Why did you change it in the first place? Was the old one doing the samething? I'm thinking maybe there is a problem with that pones SIM reader.



I'm a Contributor Level 1

Hi @KAPABLE-K,

 

It's still not working in the newer iPhone.

 

I was given the 7Plus when a friend upgraded to a newer one and it was working for her. My old SIM didn't work in it, so I troubleshooted on the Apple Support website. It suggested my SIM might need to be updated to work in the newer iPhone. I called Fido, explained the situation, and the Customer Service Rep agreed that I needed to upgrade to a new SIM card. So the old SIM worked in my iPhone 6 and 7Plus and the new one works in my iPhone 6, but not the 7Plus. So the SIM card wasn't the issue.

 

I called Apple Support yesterday and nothing that the Rep suggested worked, so I'll have to call them back today. It's very frustrating because I've never had a SIM card not work in a phone.

 

Thanks for checking up on my issue Smiley

I'm a Contributor Level 1

Sorry @KAPABLE-K, I meant to type my old SIM worked in my iPhone 6, but not the 7Plus, and it's the same with my new SIM.

Hey @GG82,

 

Which provider was the iPhone with that was given to you? Maybe it is locked to the previous carrier if it's not from Fido.

 

I was doing a bit of digging around and came across this.



I'm a Contributor Level 1

Hi @KAPABLE-K,

 

The iPhone was with Rogers and the first thing I asked my friend to do was call them and unlock the iPhone, when my old SIM card didn't register in it. She rang them and was told it wasn't locked.

 

Thanks so much for your help! I checked out the link and unfortunately the model number on the 7 doesn't match any of the model numbers on the website.

 

I really appreciate you doing a bit of digging around!

 

I'm about to schedule a callback with Apple Support.

Hey @GG82

 

You've mentioned

So the old SIM worked in my iPhone 6 and 7Plus and the new one works in my iPhone 6, but not the 7Plus.

This could still be SIM related. That said, have you had the chance to try a non-Fido SIM card in your iPhone 7 Plus as well? This would help you narrow it down a bit.

 

Also, if your friend was not the original owner of the device, it would be a good idea to check the status of the IMEI, using this link

 

Let us know how it goes with Apple support so we can follow up Smiley



I'm a Contributor Level 1

Hi @FidoSaad,

 

Thanks for your help and suggestions. I really appreciate it!

 

Sorry, when I typed 'So the old SIM worked in my iPhone 6 and 7Plus and the new one works in my iPhone 6, but not the 7Plus,' that was a typing error and my next message to Kapable-K explained that.

 

What I meant to type was the the old and new SIM work/worked in the iPhone 6, but neither of the SIMs work/worked in the 7 Plus. So that made me think it wasn't a SIM issue.

 

I haven't tried a non-Fido SIM card as my husband is with Fido too and our neighbours are socially distancing, so that option won't work for now. 

 

The link you sent was a big help because my friend was the original owner (as she bought the 7 Plus brand new), but she did lose the phone, reported it as lost and then found it in her basement! I typed in the IMEI and it came up as blacklisted! I Googled what to do and it said to contact my carrier, or have her call hers, to get it unblocked. Do you know if Fido can unblock it, or does she have to call Rogers and they do it?

 

Apple Support ended up escalating my issue as none of the troubleshooting suggestions worked, and I've spoken to 3 different Support Techs! They think it's an issue with the phone as they've had a lot of the same issues reported with the iPhone 7 and 7 Plus (phone saying 'Searching' or No Service' even when there's an activated SIM card in the phone). They want to get it sent for repairs and are in the process of organising that. I'm getting a callback tomorrow. 

So now I'm not sure if I should go ahead with the repair? I'm going to try and get the phone unblocked as quickly as I can in case that's been the issue the whole time.

 

Once again, thanks for helping me and following up on my issue 😊

Hey @GG82,

 

Glad to learn you were able to figure it out! Only the original provider that blacklisted the phone can remove it from the blacklist, so your friend will need to contact Rogers to request this. 

 

The device should work after, you might not need to send it in for repair. 

 

Keep us posted! Smiley

 

 



I'm a Contributor Level 1

Hi @KAPABLE-K@FidoSaad & @FidoClaudia,

 

I just wanted to give you guys an update on my iPhone 7 Plus saga!

 

I contacted my friend to ask her to call Rogers and get the phone removed from being blacklisted. She told me she couldn't because when she reported it to Rogers as lost, they sent her a replacement phone and the lost phone (which she ended up finding in her basement-sorry I think I'm repeating myself!) can no longer be used because of the replacement phone. She totally forgot to mention that minor detail to me! 😐

 

So now I have a phone that can only be used if there's wifi.

 

Anyway, I logged into my Fido account and ordered a new phone online. It should get to me in a few days.

 

I contacted Apple Support and told them not to worry about sending the phone for repairs. Case closed.

 

Thanks so much to all of you for your help, suggestions and getting back to me so quickly. Thanks @FidoSaad for directing me to the website for blacklisted phones.

 

Take care guys 😊

 

 

I'm a Contributor Level 1

Hi @FidoClaudia,

 

Thanks for the info! I'll call my friend and ask her to call Rogers.

 

It's great to finally know what the issue is! 😊