Account page is absolutely useless

Account page is absolutely useless

Account page is absolutely useless

SOLVED
TetraVaal
I'm Helpful Level 1

Account page is absolutely useless

Everytime I'm loggin in to my account page, it seems there's a bug that prevent me from seeing any of my informations (bills, device balance, etc). I basically see a blank space with a loading icon, which load nothing forever. 

 

I'm using Chrome, latest version. 

 

Fido's website is very heavy on javascript. I remember a time when websites were just HTML/CSS and images. Now every website wants to be a app, loading a bunch of script in the background for no reasons. 

 

Accepted Solution

Re: Account page is absolutely useless

Solved by I'm Helpful Level 1

Tried again, this time without my ad blocker and it worked. 

View solution in context
5 REPLIES 5
Freerider7
I'm a Participant Level 1

Fido's web site is still very, very, very, unfriendly to its users.

I've been trying to access features in my account on-line and the web page is in a contunous refresh, not unlike the endless boot loop of my LG3; customer service has limitations to help. I have been so frustrated with this service provider. I am without a phone and questioning if I even need one now knowing I can't rely on hardware or this service non-provider.

Hello @Freerider7. This doesn't sound right to me.

 

Can you give us more details on what happens when you try to use the website?


Are you getting an error message on your end?

 

Also, which browser are you using (Google Chrome/ Internet Explorer / Safari)

 

Let us know.



FidoJulien
Moderator (inactive)

Hey @TetraVaal

 

I'm sorry to learn you're having trouble accessing your information on the website.

 

Are you using your phone number or an email address to login?  Also, did you try clearing your cache and deleting the cookies?  If you didn't I'd suggest doing that and trying again.

 

Let us know how it goes! Smiley



TetraVaal
I'm Helpful Level 1

Tried again, this time without my ad blocker and it worked. 

FidoPierre
Moderator (inactive)

Hey @TetraVaal

 

I am happy to see this worked out for you! Very_Happy