Ethernet doesn't work properly with hitron modem

Ethernet doesn't work properly with hitron modem

Ethernet doesn't work properly with hitron modem

I'm a Participant Level 1

Ethernet doesn't work properly with hitron modem

I just started using the Fido service 2 days ago. I'm observing problems connecting to the internet via the ethernet ports on both my Linux and MACOS computers. I also couldn't get it to work with my Apple TV2.

 

What wrong or different about the ethernet ports on the Fido Hitron modem?

4 REPLIES 4
I'm a Participant Level 2

Hi did you resolve this? I have the same problem with the new modem setup. It seems like only the first device that I connect to the modem is the only one that gets internet. My Apple TV will or any other device will not get internet through Ethernet connections. 

Hello @User129076543,

 

Welcome to the community! 

 

What have you tried up until now to fix this? 

Have you tried rebooting your router? 

 

You're welcome to contact our technical support department here so they can take a deeper look with you. 

​​​​​​​



I'm a Participant Level 2

Hi. I called technical support and we reset the line. Tech helped me to localize the issue to a settings issue in my own equipment. I resolved the settings issue myself from there and everything is working fine. Thanks!

I would mention that the provided hitron modem/router needs to be put in bridge mode. The router functionality is too weak to support multiple device routing. My Ethernet connection kept on crashing / dropping when I tried gateway function on hitron. Need to use a separate router.

Moderator

Hey @cbgregoire! Philippe here. Welcome to the community. Smiley

 

I'll be happy to help you with your modem, but I'll need to ask you a few questions to see what's up:

 

1. Have you tried to restarting your modem to help with this?

 

2. Are you getting an internet connection from any of your ethernet ports?

 

If you're still have the problem after restarting, I recommend contacting our technical support line here, so they can run some tests.