Showing results for 
Search instead for 
Did you mean: 

5 hours of extra data not working

I'm a participant level 2
I'm a participant level 2

Good morning,


I am trying to use the 5 hours of extra data since last month, and it doesn't seem to be working! The Fido App is up to date, the phones OS is up to date as well. When I select the Extra Data I see error messages at different places. The messages are either "something went wrong" or "no connection" when I clearly am connected to the Fido network.







I'm a participant level 1
I'm a participant level 1

It happened to me when I added another account. I fixed this by choosing my number from the top drop down number. Somehow to app defaults to the number I am not using.

@Macy that's because you are logging in with your email and password you have to choose not the account holder and use your phone number this way every time you open the app it just shows the info for your number.

Community Manager (Retired)
Community Manager (Retired)

Hey @AnomalyOd,


Are you logged in to your account on the app when you're trying to access Data Bytes? If you are, you would need to log off to see the option.


You would also need to make sure to log in with your phone number. If the phone number authentication isn't set up when logged in with your username and password, you can set it up by following these steps on the app:


  1. Go to More tab.
  2. Select Your Profile and Settings.
  3. Go to the Settings tab.
  4. Select Sign in using Fido wireless phone number and complete the steps.
  5. Follow Log In to My Account App for the First Time Using an Authorization Code.
  6. Once the number authentication steps are complete, you should see the 5 Extra hours of Data banner.

If that doesn't solve it, please reach out to us so we can take a closer look.

I'm a participant level 2
I'm a participant level 2

Hi FidoClaudia,


thank you for the response. I do see the option of data bytes, I just can't use it because of the error messages that I showed in the original post.


yes, I am logged in when I'm trying to access the bytes, I also tried logging out and in again. It also didn't help.


once again, the issue is not that I can't see the option itself, it's that when I try to use the bytes - I see error messages and it doesn't work.

Hey @AnomalyOd! Philippe here.


Have you tried to uninstall and reinstall the app?


If yes, or if that doesn't work, I suggest you contact us here for support.