Unable to Finalize FidoTRADE

Unable to Finalize FidoTRADE

Unable to Finalize FidoTRADE

SOLVED
I'm a Participant Level 2

Unable to Finalize FidoTRADE

I recently got a new phone and plan with Fido, and am trying to trade in my old Samsung Galaxy S8, but it won't let me finalize the trade.

 

I go through the whole process, both through the click-through link from onlinefidotradequote.com (which eventually redirects me back to Fido.ca to log into my account and start the process, and directly from Fido.ca > My Account > View Usage and Manage > Repair or trade-in device.

 

I then continue with the Fido app on the phone I'm going to trade in, and run diagnostics. Battery, gyroscope, buttons, sensors, everything works, and yet once I click the "I'm Done" button on my computer, I'm just met with a blank page on the pop up (other than a back button).

 

I've tried using different browsers (Chrome & Mozilla), and both had the same results. Can someone help me out with this before I miss the trade-in offer (if it expires)?

Accepted Solution

Re: Unable to Finalize FidoTRADE

Solved by I'm a Participant Level 2 KimberlyC

Thanks! 😊

 

I actually emailed the company in charge of the trade-ins (BrightStar) and they said that I could complete the trade-in without the diagnostic.

In an email they told me that "When you get to the Device Diagnostics step of the trade process, click the "Unable to Run MyAccount" button at the bottom to bypas the diagnostics and proceed" which worked for me.

 

Thank you for your help though!! 😅

View solution in context
3 REPLIES 3
Moderator

Hey @KimberlyC! Philippe here. Welcome to the community. Smiley

 

Do you have any pop-up blockers setup on your browser? If yes, turning them off may help with that.

 

If not, try clearing your browser's cache and cookies to see if that helps.

 

Let us know how it goes!



I'm a Participant Level 2

Thanks! 😊

 

I actually emailed the company in charge of the trade-ins (BrightStar) and they said that I could complete the trade-in without the diagnostic.

In an email they told me that "When you get to the Device Diagnostics step of the trade process, click the "Unable to Run MyAccount" button at the bottom to bypas the diagnostics and proceed" which worked for me.

 

Thank you for your help though!! 😅

Thanks for the update @KimberlyC!