Sony X10...new phone having some issues

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Sony X10...new phone having some issues

Hello, just got the Xperia X10, unlocked and trying to set it up. Got the data plan added and have no problem getting internet on the phone. Having trouble with a few other things....when I try to set up google account to be able to do everything it won't let me it says it can't establish reliable data connection to server. Is this an issue with the set up of the phone or the data plan?

 

Thanks for any help

 

 

***Edited to add labels***

Accepted Solution

Re: Sony X10...new phone having some issues

I have a X10 and it works fine ...

Maybe you should setup a google account first with your pc then login on your x10 ...

Also maybe try to set it up using wifi connection

View solution in context
Flag this to a Moderator
Message 1 of 4
2,425 Views
Highlighted
Community Manager (Retired)
Community Manager (Retired)

Re: Sony X10...new phone having some issues

 

@community

 

Can anyone help out x10 with a connection issue?

 

Thanks



Flag this to a Moderator
Message 2 of 4
2,408 Views
Highlighted
I'm Helpful Level 2
I'm Helpful Level 2
Solution

Re: Sony X10...new phone having some issues

I have a X10 and it works fine ...

Maybe you should setup a google account first with your pc then login on your x10 ...

Also maybe try to set it up using wifi connection

Flag this to a Moderator
Message 3 of 4
2,402 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: Sony X10...new phone having some issues

What happens if you turn off your data, and use wifi? I never had issues with setting up my accounts....

Flag this to a Moderator
Message 4 of 4
2,296 Views