Samsung Galaxy Ace S5830 with Fido data plan

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Samsung Galaxy Ace S5830 with Fido data plan

Hi there - I have signed up with Fido's data plan today with a non-Fido phone. I have set up the APN settings as:


Name: Fido Internet/MMS

APN: fido-core-appl1.apn

Proxy: <not set>

Port: <not set>

Username: <not set>

Password: <not set>

Server: <not set>

MMSC: http://mms.fido.ca

MMS proxy : 205.151.11.13

MMS port : 80

MCC : 302

MNC : 370

Authentication type: <not set>

APN type: default,supl,mms

 APN protocol IPv4


I have put a check mark next to "Use Packet Data" and "Data Roaming" (without both these being check marked I cannot connect to the internet).
Now, my question is - the phone is not showing that it's connected to a 3G network (the phone is NOT set to connect to 2G only). I only show a tiny E with 2 arrows going up/down - assuming I'm connected to Edge?
This phone was purchased outside of Canada and it's unlocked. I'm aware of the R for roaming because of the non-Fido phone issue. But how do I get the phone to connect to 3G? It's a 4-band phone..

 

 

***Edited to add Labels***

 

Accepted Solution

Re: Samsung Galaxy Ace S5830 with Fido data plan

turns out it doesn't support Fido's 3G frequency Sad so I'm stuck with Edge network for now

View solution in context
Flag this to a Moderator
Message 1 of 6
5,320 Views
Highlighted
I'm Qualified Level 1
I'm Qualified Level 1

Re: Samsung Galaxy Ace S5830 with Fido data plan

Instead of  APN: fido-core-appl1.apn

Try APN : internet.fido.ca

 

Netwok frequency for Fido : 850/1900

Flag this to a Moderator
Message 2 of 6
5,316 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2
Solution

Re: Samsung Galaxy Ace S5830 with Fido data plan

turns out it doesn't support Fido's 3G frequency Sad so I'm stuck with Edge network for now

Flag this to a Moderator
Message 3 of 6
5,307 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: Samsung Galaxy Ace S5830 with Fido data plan

If the phone is picking up 2G but NOT the 3G, perhaps the phone has a 3G frequency that is not one that fido uses? this usually happens when your phone goes down to 2G

as for internet, if you can get on the internet, its working, although it will be a slower EDGE connection it should still work
Flag this to a Moderator
Message 4 of 6
5,297 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: Samsung Galaxy Ace S5830 with Fido data plan

the phone is compatible with - 850/900/1800/1900 MHz for HSPA,  FiDo uses the same frequencies.

Flag this to a Moderator
Message 5 of 6
1,669 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: Samsung Galaxy Ace S5830 with Fido data plan


@sureo9 wrote:

the phone is compatible with - 850/900/1800/1900 MHz for HSPA,  FiDo uses the same frequencies.


 

Hello Sureo9,

 

  Welcome to the forums!

 

  Thanks for the input, but I think it's pertinent to note that the phone's bands/frequencies depends on the version of the phone. For example, GSMArena shows 2 different versions, one with compatible '3G' bands/frequencies and one without. Unfortunately for the OP, the version they had did not have compatible bands/frequencies for '3G'. It appears as though the version you note does have compatible bands/frequencies. Do you know which version those specifications are from? It may help any other users with queries about this phone.

 

Cheers


Flag this to a Moderator
Message 6 of 6
1,659 Views