NEXUS 5 on LTE not working

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

NEXUS 5 on LTE not working

I have a nexus 5 from Google play, support LTE: Bands: 1/2/4/5/17/19/25/26/41 which means that at least it support 1700Mhz and 2100Mhz but not 2600Mhz. Still I do not see LTE indication on it as I was expecting. The setting is on LTE as preference band. Any idea why LTE is not working?

 

 

***Edited to add labels***

 

Accepted Solution

Re: NEXUS 5 on LTE not working

You will also need an LTE specific SIM card to use LTE. Fido currently sells all SIM cards with LTE enabled. Its just a matter to poping into a fido store and pay $10 for it.

 

Also note that if you are on the PREPAID plans you will only get 3G speeds, even if your Phone and SIM card is LTE capable.

View solution in context
Flag this to a Moderator
Message 1 of 4
1,916 Views
Highlighted
I'm Qualified Level 3
I'm Qualified Level 3
Solution

Re: NEXUS 5 on LTE not working

You will also need an LTE specific SIM card to use LTE. Fido currently sells all SIM cards with LTE enabled. Its just a matter to poping into a fido store and pay $10 for it.

 

Also note that if you are on the PREPAID plans you will only get 3G speeds, even if your Phone and SIM card is LTE capable.

Flag this to a Moderator
Message 2 of 4
1,913 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: NEXUS 5 on LTE not working

Thanks a lot for the info, will go to get LTE enable card

Flag this to a Moderator
Message 3 of 4
1,897 Views
Highlighted
I'm Qualified Level 1
I'm Qualified Level 1

Re: NEXUS 5 on LTE not working

You'll need to change your APN settings as well. Perhaps the fido rep will change them for you when you pickup the LTE sim.
Flag this to a Moderator
Message 4 of 4
1,795 Views