Lte sim issue samdung s3

Lte sim issue samdung s3

Lte sim issue samdung s3

I'm a Contributor Level 1

Lte sim issue samdung s3

I have a unlocked s3 from Rogers. I got it last week. I use an lte sim that I cut to fit.
I have the settings to letmobile.apn. Everything was good for over 1 week
Today I can't connect to lte. I only get 4G. Half the time I have no service.
I called fido but they don't know what to do. They reset my sim but that didn't work. . Any ideas?? :
Thanks.

 

 

***Edited to add labels***

5 REPLIES 5
I'm a Participant Level 3

LTE has come back for me in Montreal since about 830 althoigh speed is still less than what it was last week so I ma not crying voctory just yet!

I'm a Participant Level 2

I got LTE back as well!  My quick tests on Speed Test does seem to suggest that Rogers has throttled back the speed, especially the upload speed. 

 

They must have reset the switch overnight with new settings.  Really hard to prove but empirical data does seem to show the network is slower.  Maybe they're getting more people connecting then they thought with Fido subscribers all jumping onboard and iPhone 5s all going online roughly the same time.

I'm Experienced Level 3

I still don't have LTE and in Toronto. Happened since yesterday and I even had problems logging in to my account.
I'm a Participant Level 2

I have LTE in Markham.  Download 11Mbps, Upload 12Mbps, not bad.  Not as high as the weekend but still not bad.

I'm a Participant Level 2

Same issue here...seems like the LTE network is down?  I lost LTE connection starting last night.  Thought it was maybe my sim card but now if others are experiencing the same thing, maybe it's the carrier.