LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

Hello,

 

I was wondering if anyone had issues with Fido's LTE network?

 

I am more concerned with any issues that may have come up for phones that weren't offered by Fido. For example the littany of android devices that Fido doesn't offer.

 

I plan to get the Galaxy Note 2 (unlocked) but I am affraid I won't get the full potential of the product as I heard there were some problems with using phones that weren't offered by Fido.

 

Thanks for any help.

 

 

 

***Edited to add labels***

Accepted Solution

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

I have the Galaxy Note from Rogers and using it on Fido with no issues. It actually worked straight out of the box. The Note 2 is definitely an improvement over the original Note. I have the Note 10.1 as well and the S-Pen is much more better when working with it.
View solution in context
Flag this to a Moderator
Message 1 of 12
7,549 Views
Highlighted
I'm Experienced Level 3
I'm Experienced Level 3
Solution

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

I have the Galaxy Note from Rogers and using it on Fido with no issues. It actually worked straight out of the box. The Note 2 is definitely an improvement over the original Note. I have the Note 10.1 as well and the S-Pen is much more better when working with it.
Flag this to a Moderator
Message 2 of 12
6,937 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

I have an I phone 5 and every so often when I get calls they would go straight to voicemail. After calling fido they just reset network but that did jack. I called apple who took the time and finally diagnosed that the LTE network is the problem. They had me turn off LTE from my settings on the phone and I instantly had full reception on my network. So, it's fido. Fido needs to sort this LTE network issues out. Thanks apple for taking the time to really diagnose this issue!
Flag this to a Moderator
Message 3 of 12
6,928 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

I bought the Motorola Razr HD outright from Rogers and am using it on the Fido Network (worked right out the box, but I unlocked it after regardless).

 

LTE works fine for me with 0 issues to date. Hopefully it stays that way.

 

The only issue I'm having is that since Fido doesn't have this phone in their system, I can't have Visual Voicemail Plus set up for whatever reason which sucks.

Flag this to a Moderator
Message 4 of 12
6,778 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)


@Imp3rial1 wrote:

I bought the Motorola Razr HD outright from Rogers and am using it on the Fido Network (worked right out the box, but I unlocked it after regardless).

 

LTE works fine for me with 0 issues to date. Hopefully it stays that way.

 

The only issue I'm having is that since Fido doesn't have this phone in their system, I can't have Visual Voicemail Plus set up for whatever reason which sucks.


Are you using APN settings for LTE, i had an iPhone 5 and LTE was working fine, but now i'm using the S3 with LTE Micro sim and don't seem to get LTE Confused

Flag this to a Moderator
Message 5 of 12
6,770 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

^^ Yeah I am.. the LTE micro sim picked up on the LTE apn settings on its own I didn't have to manually input it.

 

Granted, the LTE speeds i'm getting are nowhere near as fast as some of the blistering speeds i've seen people post elsewhere (I'm getting about 14Mbps down and 3Mbps up) but I've only ran the test once and only in one location (at home, in Scarborough)

Flag this to a Moderator
Message 6 of 12
6,747 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

Visual Voice mail does work for the Razr HD. i just got one and fido set it up for me.

Flag this to a Moderator
Message 7 of 12
6,740 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

Visual Voicemail or Visual Voicemail *Plus*?? They told me that since this phone isn't in the fido database or network or whatever that visual voicemail PLUS will not work.

since you have the same phone.. by default when you put in the fido lte micro sim in the phone it already has some fido apps on there (fido store, my account and VVM Plus).. I get 2 alerts in the notification area at the top.. 1 saying that i'm not subscribed to VVM Plus and the other saying there's a network outage for VVM Plus.
Flag this to a Moderator
Message 8 of 12
6,737 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

I'm in the same boat as you.
Got an s3 after an iphone 5, brand new sim (so none of the apparent iphone sim affecting Data problem), but I'm still not getting LTE.
I have the correct apn set up and even when in areas where I had lte on my iphone 5 (Kanata, just outside ottawa) I get only H+.

Any help out there?
Flag this to a Moderator
Message 9 of 12
6,681 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: LTE on unsupported Fido phones (Samsung Galaxy SIII, Galaxy Note 2, etc)

G-Slide: you are correct! I called back fido and apparently the previous agent didn't setup my visual voicemail plus correctly so now all is good Smiley Thanks!

 

as a follow up to the LTE.. since you guys both have the S3 maybe it's some setting within the S3 causing the issue? I tested LTE speeds at work today (Markham, Ontario) and I got 16Mbps down and 20Mbps up on my Razr HD

Flag this to a Moderator
Message 10 of 12
6,659 Views