LG G4 US991 not connecting to 4G. Also signal seems to drop out often

LG G4 US991 not connecting to 4G. Also signal seems to drop out often

LG G4 US991 not connecting to 4G. Also signal seems to drop out often

SOLVED
I'm a Participant Level 3

LG G4 US991 not connecting to 4G. Also signal seems to drop out often

I recently got a LG G4 US991 for christmas (yay).

I do not know which specific model of US991 it is, because apparently there are two: LTE-A and TD-LTE.And do not know how to find out.

 

Checking on Frequencycheck.com:

LTE-A supoorts 2/3 LTE bands.

 

Interface     Name            Supported by device?
LTE     B4 (1700/2100 AWS 1)     Yes
LTE     B7 (2600)                          No
LTE     B17 (700 bc)                      Yes

 

TD-LTE supports 1/3 LTE bands

Interface     Name                   Supported by device?
LTE     B4 (1700/2100 AWS 1)     Yes
LTE     B7 (2600)                           No
LTE     B17 (700 bc)                       No

 

BTW, my phone is always connected to 'H' when my data is turned on. Which by the way, I had to configure my APN settings to get it, of which I'm not even sure if I did right, but since I'm online, it'll do for now.

 

Judging by this, one would assume that perhaps I have the TD-LTE since I'm never on 4G but I'm not in a very secluded part of the city (I live in Vancouver and am always around the Metrotown area and work around Oak st and 12th, a pretty bustling area) so I would assume that at least ONE point in time I would see the 4G network. Nope.

 

Any advice on what's going on? I used this sim card on a previous phone (LG G3) and I connected to 4G fine.

 

Another issue I've noticed is that sometimes my signal just cuts out. Like I'm on airplane mode. It drops for a few seconds and then I regain it again. This did NOT happen until I configured my APN settings to get data. Prior to adjusting my APN settings, I was able to send texts/phone calls and had full bars of signal (just no data). It was only after I configured APN to get data, that I started having shady connections. Which leads me to believe I may have made an error in configuring my settings.

 

My APN settings are:

 

Name: fido internet
APN: internet.fido.ca
Proxy:  blank
Port: blank
Username: fido
Password:  fido
Server:  blank
MMSC: blank
MMS proxy: blank
MMS port: blank
MCC: 302
MNC: 370
Authentication type: default
APN type: default
APN Protocol: default

 

ii) Name: fido mms
APN: mms.fido.ca
Proxy:  blank
Port: blank
Username: fido
Password:  fido
Server:  blank
MMSChttp://mms.fido.ca
MMS proxy: 205.151.011.013
MMS port: blank
MCC: 302
MNC: 370
Authentication type: default
APN type: mms
APN Protocol: default

 

This is the only way I got my phone to work. Previously I had exactly what the support forums tell me to put in, and it worked for my OLD phone (LG G3) which also had moments where I was dropping signal just like I am now, but I had 4G. I also tried that configuration for my NEW phone (LG G4) but it doesn't work.

 

I am also set on the preferred 'Global' network, as the phone was set at as default. My other choices are 'LTE/CDMA' (which just shuts off all cellular signal and never comes back when I select it) and 'GSM/UMTS' which acts the same as 'Global' where I get H data and occassional signal drop.

 

Long winded message and I thank you for reading it. If anyone has ideas, let me know please. I will try them and get back to you ASAP.

 

Thanks,

Jason

 

 

***Edited to add labels***

Accepted Solution

Re: LG G4 US991 not connecting to 4G. Also signal seems to drop out often

Solved by Senior MVP Senior MVP

Hello again,

 

  After a quick search, try editing the APN type in ltemobile.apn to: default,dun,fota 

(see here and here)

 

  I understand they refer to issues following the Marshmallow update, but even if you don't have Marshmallow, it's worth a try...

 

Hope this helps Smiley

 

Cheers

 

View solution in context
9 REPLIES 9
Senior MVP

Hello Thatyug,

 

  Welcome to the community!

 

  If you purchased the phone on newegg.ca, it's likely the not the TD-LTE version. Judging by the specifications listed on the LG website here, the phone should have 3 of the compatible bands (4, 12 and 17). The phone should also have all of the compatible bands/frequencies fore 2G and '3G'. **edit** You can verify the compatible bands/frequencies here.**

 

  Since the phone is LTE-capable, it should be using the single ltemobile.apn. You can verify the correct settings here

 

  Judging by your available network settings, I believe the correct setting should be Global.

 

**edit** After re-reading your post, you note that you used to get signal drops with your old phone as well? Coverage depends on your location relative to the cellular towers. If a device does not have all of the compatible bands/frequencies, coverage would also depend on the bands/frequencies of those surrounding towers. You can get an idea of where the cellular towers are here. Even if there are cellular towers in the vincinity, cell signal could get blocked by obstructions such as buildings between your location and the towers.**

   

Hope this helps Smiley

 

Cheers


I'm a Participant Level 3

Hi again,

 

I have configured the APN settings via your link and used LTEMOBILE.APN

I do not have data coverage. Nothing appears, not even the H.

I tried the Fido-core-appl1.apn as well - nothing.

 

I tried both options with ROAMING enabled - nothing.

 

Could this be a phone/sim defect? Although my sim card worked in my G3 phone.

 

Jason

Hello again,

 

  Hmm, that's strange...

 

  Are you able to try your SIM in a different phone again? They can sometimes get damaged. Alternatively, you might also consider trying a different SIM in your phone. If you don't know anyone else with Fido, you could visit a Fido location and ask if you could test one of their SIMs.

 

  To clarify, did you restart your phone after changing the APN settings? Additionally, have you tried ltemobile.apn as all small letters? I know some phones have been tempermental that way. 

 

  I mentioned above that I thought the correct network setting was Global. However, you might consider trying the other settings as well. That said, the other settings seem like they would have limitations:

LTE/CDMA - would only allow LTE since Fido/Rogers does not operate CDMA

GSM/UMTS - would only allow 2G and/or '3G' 

 

  You might consider trying the LG android codes to access the network settings via the service menu. Occasionally, they have additional options available.

 

  Additionally, to be clear, you were able to get adequate signal with your old phone on Rogers at your current location? 

 

  Just a quick note regarding roaming... Assuming that plan is eligible for Extended coverage, roaming on the other networks as Fido-EXT will not incur additional charges. However, travelling outside of Canada (and outside areas of extended coverage) will incur roaming fees (unless you purchase travel pack or Fido Roam).

 

**edit** When you try those network setting changes, what (if any) networks show as available when you search networks manually?**

 

Hope this helps Smiley

 

Cheers


Hello again,

 

  After a quick search, try editing the APN type in ltemobile.apn to: default,dun,fota 

(see here and here)

 

  I understand they refer to issues following the Marshmallow update, but even if you don't have Marshmallow, it's worth a try...

 

Hope this helps Smiley

 

Cheers

 


I'm a Participant Level 3

HOOOOOOOOOOOOOOOOOO

 

To quote that other guy from the linked thread, SWEET BABY JESUS IT WORKED

 

I now have 4G LTE.

 

I used the LTEMOBILE.APN settings in caps and added in the 'default,dun,fota' saved and restarted my phone. At first it didn't do much, still connected to HSPAP, but then the lord smiled upon me and granted me access to LTE :D:D

 

Sorry Cawtau, I didn't get a chance to test out the other options, such as using the ltemobile.apn in small fonts. I decided to try the US991 fix in your second post because it would take the least amount of time. If it didn't work, I would have attempted your other suggestions the next morning as it is quite late now.

 

I don't know if this will fix my signal droppage, but for the time being, this is a win for me. And other US991 users out there.

 

Thank you so much Cawtau. I wish you happy holidays!

 

Jason

Hello again,

 

  That's awesome! I'm glad that worked for you! Very_Happy

 

 Happy New Year! 

 

Cheers


Hello again,

 

  Something else that came to mind if the above doesn't seem to fix your issue. Have you enabled roaming data? The phone was made for US Cellular and I believe they are CDMA-based. It's possible that they require roaming data enabled to work properly on other networks. 

 

  Also, just to be certain, is the phone unlocked?

 

Hope this helps Smiley

 

Cheers


I'm a Participant Level 3

HELLO CAWTAU

 

Thank you so much for your input.

To answer your question first, Yes the phone is unlocked.

 

I will attempt to reconfigure my APN settings and get back to you soon.

 

Just some extra information in regards to your post.

Previously, when I was a Rogers customer, I was using the LG G3 with no proglems. No signal drop like I am experiencing now. I became a Fido customer during their 40$ 4GB promotion plan (as many people did), got a new sim card but retained my old G3 phone.

 

When I had that issue, I configured my APN settings with  the standard settings, not the LTEMOBILE.APN setting. This gave me data but that's when signal droppage became an issue.

 

Now on my G4, it is the same new sim card that I got from Fido and moved over to the new phone, plugged in the two APN settings I mentioned in my original post and had the same issues as my G3 in terms of signal droppage.

 

I will go eat dinner and apply the new APN settings that you have linked and get back to you.

 

Thanks again for your advice, please stay tuned in case the solution doesn't work!

 

Jason

 

*EDIT - question regarding 'Roaming' - I have it set to off because I do not want to incur any roaming charges. I have always had it like that back when I was a Rogers customer. If I set it to on, will I get charged fees?

I'm a Participant Level 3

The phone is from newegg.ca

And it looks like it was made for a company called US Celluar.

 

If that information helps anyone.