Showing results for 
Search instead for 
Did you mean: 

LG G4 -- Problems with recent OS Upgrade

I'm a participant level 2
I'm a participant level 2

I bought an LG G4 android smartphone last Sept and started my Fido account.  Up until 4 days ago, it's been a great phone -- easy to set up and no problems.  The camera is awesome.  

Four days ago, it did an automatic *major* upgrade -- I believe of the phone's OS -- I believe to V6.0.  Since then, there are a number of features that have either stopped working or are intermittent.  The LG AirDrive no longer works.  Access to Fido data is intermittent.  When it tries to download app upgrades, they 'hang' -- unable to stop or finish.

I've sent emails to the LG support dept with no answers -- will continue to chase them.

Has anyone else come accross this issue?

I bought the phone at Costco -- if I can't resolve this, I'm taking it back and getting a new one (but it sure won't be an LG....!)



** Edited to add labels **



Try clearing your cache partition.


LG G4 Wipe Cache Partition

  1. Launch the Settings Application
  2. Tap on the General Tab(if in tabbed view)
  3. Scroll Down and Tap on the ‘Storage’ Option
  4. Locate the ‘Cached Data’ Option and Tap on it
  5. Confirm the Task by Tapping on the ‘OK’ Option
  6. Reboot the LG G4

If you still get problems do a full factory reset I would recommend this after doing a full OS upgrade.

I'm a participant level 2
I'm a participant level 2

Thanks for this, Kapable-K.  

I'd also got LG via their on-line chat, and was told by their agent to do the factory reset.  Before doing it, backed up via LG Bridge to my laptop.  Then transferred the backup back to the phone afterwards.  The whole process took about an hour, and it has *mostly* solved all the problems.  The only thing still not working is LG AirDrive, that permits wireless communication between the phone and my laptop.  But I can still transfer via hardwire to the USB port.

If anyone wants to do this with their LG G4, there is a pretty good youtube video that shows the tricky 'button press sequence', here:

Thanks again