Huawei mate 20 pro could not send message after emui 10 upgrade

Huawei mate 20 pro could not send message after emui 10 upgrade

Huawei mate 20 pro could not send message after emui 10 upgrade

SOLVED
justinren
I'm a Contributor Level 1

Huawei mate 20 pro could not send message after emui 10 upgrade

I just upgraded my mate 20 pro to emui 10 through the official update from the phone itself. Before the update, everything is functioning well. After the update, I am not able to send text message to any iphone users, but somehow I can send picture message to them. I am not able to send text message to android users sometimes as well, but 80% of time I can send message successfully to android users. Any thought how to solve this? I am using the default messages app only

Accepted Solution

Re: Huawei mate 20 pro could not send message after emui 10 upgrade

Solved by MVP MVP

Hey @justinren, try clearing the text app cache that you are using if the problem is still there then a factory reset might have to be done. I always recommend a factory reset after any major updates to avoid any issues.

View solution in context
18 REPLIES 18
raywen
I'm a Participant Level 1

got same problem

Hey @raywen! Welcome to the community. Smiley

 

We can confirm that it is a known issue with Huawei, and they are looking into it. The affected devices have:


SMS App version: 5.2.062 or later,
Kernel 4.14.116 or later, build 10.0.0.178 or later, Android Version 10.

 

The affected users would need perform these steps and verifications:

 

- Delete the SMS message, retype it, and try sending it again.

- Enable and then disable Airplane mode to reactivate the network.

- If your phone is unable to receive messages sent from select numbers, it may be because those numbers have been saved to PrivateSpace. In this case, open Settings, search for and access PrivateSpace, open Messaging and check whether there are any received messages. If so, transfer the corresponding contacts you need to MainSpace and try again.

- Check whether the number has been added to the Blocklist and whether Block strangers has been enabled.

 

Let us know if these troubleshooting steps helped!



Ccantin288
I'm a Participant Level 1

None of those thing as work, I can't not send a SMS with my phone on emui 10

 

Hey @Ccantin288

 

Welcome to the community! 😃

 

For anyone having the problem where you cannot send SMS after updating your device to EMUI 10 update, this should fix the issue. (No device reset required).

 

Install the HiSuite app on your PC.  Set up your phone as instructed by following the screen prompts.

  1. Use HiSuite to backup (Optional - You can back up your device just to have it done but is not necessary)
  2. Use HiSuite’s App Manager to uninstall the Messages app (can’t be uninstalled on the phone)
  3. Use Play Store to reinstall Messenger.
  4. Use Messenger - SMS should work.

I hope that helps anyone else having this problem.

 



KAPABLE-K
MVP

Hello @justinren,

 

Try wiping the cache partition, you can follow the instructions here.



justinren
I'm a Contributor Level 1

Hello @KAPABLE-K, thanks for helping out.  just tried it, still not working.

Hey @justinren, try clearing the text app cache that you are using if the problem is still there then a factory reset might have to be done. I always recommend a factory reset after any major updates to avoid any issues.



justinren
I'm a Contributor Level 1

Thanks @KAPABLE-K . Factory reset did solve the problem, although I have to say I hate all the hassle I have to do with all my apps and settings, but I guess thats the only way. Thank you

Hey @justinren

 

Factory resetting is never fun but I'm happy you got it working, enjoy!



justinren
I'm a Contributor Level 1

Update: unfortunately it only worked for 1 day, now I cant send message again. I do not want to factory reset again

Hey @justinren,

 

It sounds like you have an app that is causing your problem. Do you have any antivirus apps installed? 

 

Try booting into safe mode and send yourself a text if it works then you will know it's an app causing the problem. You will have to uninstall apps one at a time to try to figure out which one is causing the problem.

 

  1. Power off the device
  2. Power it back on
  3. When you see the Huawei animation on the screen press and hold volume down button
  4. You will see safe mode at the bottom left corner once the device finishes booting


justinren
I'm a Contributor Level 1

Cant even send it in safe mode, even to myself

@justinren do you have access to another phone that you can put the SIM card in to test? 



justinren
I'm a Contributor Level 1

Yes I just tested it with an old p20 pro and I am able to send message

@justinren so it's definitely something on the phone.

 

Insert the SIM card back to the phone and see if it works, sometimes the SIM needs to be re-seated.



justinren
I'm a Contributor Level 1

Still not working

@justinren,

 

Try clearing the message app cache and data and see if it works, do you have lots of messages saved? Sometimes having lots of saved messages causes problems.

 

You can also try doing a network reset.

 

When you did the factory reset and setup did you do a restore or new setup? I know you will not like this but you might have to reset again and this time do a new setup and test before installing any apps.



justinren
I'm a Contributor Level 1

Thank you @KAPABLE-K 

 

None of the option other than factory reset work. For now I will just use the other phone to send message when I have to. I will do another factory reset when I have the chance.