Galaxy Nexus - Weak signal: office building, home [on 1st floor] & rural areas Kanata and Perth Ont

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Galaxy Nexus - Weak signal: office building, home [on 1st floor] & rural areas Kanata and Perth Ont

I just got the Galaxy Nexus smartphone with the $57/month program and I'm not happy with the signal I'm getting in: my downtown office [Edge 1 - 2 bars]; my home [in the city] on the 1st floor of a 2 story house [3G 1 - 2 bars and sometimes lower] and in the rural areas between say Kanata and Perth.  The signal's a little bit better ourside of my home.

 

Initially I was provided a LTE Sim card and found out it didn't work properly with the Nexus. So I've now got a regular Sim card.  The signal is still the same in my office and home.  I ran the Speedtest in both places and the results are very poor [around 15KB/s].  Of course the signal was amazing in the Fido store I was in [almost 5MB/s download].

 

I also have a Bell Blackberry 9800 cell phone and the signal is better on it.

 

Anyone experienced this ?  Any ideas to correct this problem ?

 

Mario

 

 

***Edited to add labels***

Flag this to a Moderator
Message 1 of 3
1,613 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: Galaxy Nexus - Weak signal: office building, home [on 1st floor] & rural areas Kanata and Pe

I am having similar issues with my Galaxy Nexus that I picked on the same plan. My wife has full signal on her iPhone and mine is sometimes two bars and sometime nothing at all. We both have fido so obviously it is the hardware. I have been trying to find a solution online but nothing yet. I am not happy might go back to iPhone Sad
Flag this to a Moderator
Message 2 of 3
1,586 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Galaxy Nexus - Weak signal: office building, home [on 1st floor] & rural areas Kanata and Pe

Any news about the signal problem since? I also have a galaxy nexus from the boxing day $56/mo deal. Before that I was still using my old nokia n-gage taco phone which has full signal bars at home (in the basement as well) and work.

 

Now with this galaxy nexus there is no signal at all 50% of the time on the main floor at home and about the same at work. To call fido customer service at home I have to put the sim card in the n-gage to make the call and not have a drop off.

 

Also as an added bunus the gprs internet no longer works with the n-gage since the day of aquireing the nexus (same sim card).

 

Any thoughts on this issue?

Flag this to a Moderator
Message 3 of 3
1,402 Views