Connected to LTE but "no Internet connection" (IPhone 5)

Connected to LTE but "no Internet connection" (IPhone 5)

Connected to LTE but "no Internet connection" (IPhone 5)

SOLVED
Foss
I'm a Participant Level 3

Connected to LTE but "no Internet connection" (IPhone 5)

So after much googling and scouring the Fido forums, I have come up with no resolution to my problem.  I have a iPhone 5 purchased from Fido.  I live in downtown Montreal.  I very, very rarely get an LTE connection, but when I do, I have no Internet connection via browser or apps.  I've tried replacing the micro SIM with a new one from Fido.  Same result.

 

Now here is the kicker, my co-worker has an iPhone 5 unlocked.  He has a Rogers SIM.  At my desk at work he has a strong LTE connection getting 30-40 Mbps connection while I get no LTE at all.  When he pops in my old and new SIM, he has the exact same problem as the connection on my phone.  So Fido runs on Rogers network.  Any ideas?

 

Accepted Solution

Re: Connected to LTE but "no Internet connection" (IPhone 5)

Solved by I'm a Participant Level 2 _borj

Fido CSRs on facebook are quite helpful actually. They were able to fix my LTE problem by discovering an app that I was running didn't work with my LTE. I have been using Onvao since my iphone4 to shrink the data so  when i installed it on my iphone 5, i didnt think it would be an issue, but turns out its the biggest culprit in running LTE.  The devs on that app hasnt bothered update their system to iOS6 let alone telling their customers of the issue.

Anyways, i find that CSRsover the phone are pretty useless and they seem like they dont care. You might want to try to contact the Fido CSRs on facebook.  They really do make an effort to make their customers happy.

 

 

Edit: removed profanity

View solution in context
11 REPLIES 11
mo21
I'm a Participant Level 1

I an in downtown Toronto M5G 2C2. I have LTE connection on Fido but the internet is not connected. 

It shows its connected to LTE but the internet is not at all working. Called customer care number number of times but no use. Do anyone know how to fix it, please?

 

FidoMaria
Former Moderator

Hi @mo21 & welcome to the Community!

 

What exactly happens when you try to access the internet. Are you getting an error message? 



_borj
I'm a Participant Level 2

I have the same problem.  My LTE worked for ONE DAY and it just stopped working afterwards.  I get the LTE signal without any problem but everytime it's enabled, I cant connect to anything. I troubleshooted this phone to no avail.. even went as far as going to the apple store to have my phone checked out.   I was communicating with Fido CSRs via facebook but they promised that a network rep will contact me soon.  It has now been 7 days and no one has contacted me. 

 

Also FYI, I am a new fido customer and the CSRs keeps telling me that my account is properly set up with LTE capability.

Foss
I'm a Participant Level 3

I have no resolution as of yet.  Basically I just have the LTE option off just so I don't get stuck with no connection.  Mine is a new line on an old account. Sad

Foss
I'm a Participant Level 3

So according to a Fido rep in the store on Ste Catherine, LTE issues are widespread for all of the Fido network.

_borj
I'm a Participant Level 2

Fido CSRs on facebook are quite helpful actually. They were able to fix my LTE problem by discovering an app that I was running didn't work with my LTE. I have been using Onvao since my iphone4 to shrink the data so  when i installed it on my iphone 5, i didnt think it would be an issue, but turns out its the biggest culprit in running LTE.  The devs on that app hasnt bothered update their system to iOS6 let alone telling their customers of the issue.

Anyways, i find that CSRsover the phone are pretty useless and they seem like they dont care. You might want to try to contact the Fido CSRs on facebook.  They really do make an effort to make their customers happy.

 

 

Edit: removed profanity

Foss
I'm a Participant Level 3

You sir have solved my headache. Once I removed Onavo and the profile, boom LTE works fine! TY! Very_Happy
_borj
I'm a Participant Level 2

NP! glad i can help! LOL and i'd preferred to be called a "miss" Tongue
extasis
I'm a Participant Level 3

Not 100% sure, but I would call Fido and check that your data plan has been udpated to an LTE-capable data plan (I recently ordered an iphone via Fido customer relations, and the rep indicated that he would have to switch my 'old' 6gb data plan to a newer one that allows for LTE data).

extasis
I'm a Participant Level 3

sorry one more thing - check that your APN is now set to ltemobile.apn
extasis
I'm a Participant Level 3

FYI I've read that you only need to call in to Fido to have them update your data plan to an LTE-enabled one if and only if your data plan was added prior to July 2010. (I was in this boat)