Showing results for 
Search instead for 
Did you mean: 

Voice message retrieval

I'm a participant level 2
I'm a participant level 2

Just upgraded my phone and updated the SIM card. When I tried to access the voice messaging centre, I was asked to enter the 10 digit cell phone number and  # key to retrieve my messages. Did that as instructed but the response was “that number is invalid”. Tried several times but still “that number is invalid”. Upgraded phones with Fido several times over the years never had any issues. What’s the problem?


Community Manager (Retired)
Community Manager (Retired)

Hey @laomian,


It sounds like maybe the Voicemail feature was removed from the account, which is why it's not working when you try to access it.


I'll send you a PM here on the Community to check it out! For any account related questions, you can also reach out to us here: here.


Talk soon!





I'm a participant level 1
I'm a participant level 1




I am trying to set up my voice mail messages, I have never set up a voice mail message on my phone previously. However, when I dialed the voicemail. I was asked to enter the 10 digit cell phone no and the pound key to retrieve my massages. I followed the instructions but it did network for me, the answer was " this number is invalid"


My phone is an iPhone 6 and I  did get it from Fido




Hey @MARIA33


I some questions for you regarding your situation 🙂


What number did you dial to reach your voicemail? Was it the "1"?


If you try to call our voicemail retrieval number directly:1 647-839-9169 is it the same situation?


If it persists you can contact us directly to have a look. We can also send you a PM on here if you prefer.

Let us know!