Usage detail not working on my fido account

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Usage detail not working on my fido account

ive been using my phone for a few days and the usage detail still showing everything as 0, it doesnt seem to work, as well where can i get the link to put that link on my blackberrry

 

 

 

***Edited to add labels***

Accepted Solution

Re: Usage detail not working on my fido account

Hi PhoneEric,

 

Are you still experiencing this issue? If your usage is till showing inaccurate I recommend calling in to report the issue so we may look into it for you.

 

You can reach us at 1-888-481-FIDO

View solution in context
Flag this to a Moderator
Message 1 of 3
2,445 Views
Highlighted
Former Moderator
Former Moderator
Solution

Re: Usage detail not working on my fido account

Hi PhoneEric,

 

Are you still experiencing this issue? If your usage is till showing inaccurate I recommend calling in to report the issue so we may look into it for you.

 

You can reach us at 1-888-481-FIDO



Flag this to a Moderator
Message 2 of 3
2,413 Views
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Re: Usage detail not working on my fido account

I am having the same problem, I have a blackberry and it showed when I looked on line earlier this week now it is telling me that I have no usage since the start of my current billing cycle.   Called Fido Cares and they are no help.... Fix this ....

Flag this to a Moderator
Message 3 of 3
1,415 Views