Samsung Galaxy Advanced from Europe can't connect to Data

Samsung Galaxy Advanced from Europe can't connect to Data

Samsung Galaxy Advanced from Europe can't connect to Data

SOLVED
anerev
I'm a Participant Level 2

Samsung Galaxy Advanced from Europe can't connect to Data

Hello!

 

I just moved from Europe to Canada and bought a Fido-SIM-card yesterday!

Unfortunately the mobile internet just won't work!

The phone I'm using is a Samsung Galaxy Advanced (I never had problems to use the mobile internet in Europe... WLAN still works).

 

I followed this guide here:

https://www.fido.ca/web/content/phonewarranty/configure_unlocked_device_guide

But that doesn't solve any problems... everything seems to be fine!

 

I would really appreciate your help!!!

(doesn't make sense otherwise to pay so much money a month without being able to use the internet)

Accepted Solution

Re: Samsung Galaxy Advanced from Europe can't connect to Data

Solved by Community Manager

Always happy to help Smiley

 

Can you enable Data Roaming in your settings? Sounds weird, since you're not roaming, but sometimes the phone can think it's roaming if it's not on its "home" network.

 

Keep us posted!

View solution in context
7 REPLIES 7
Dianasrodgers
I'm a Participant Level 1

I was having the same issue with my Samsung from the US and this post helped me solve it! Thanks so much!

That's what we're here for Smiley 



FidoStephen
Community Manager

Hi anerev and welcome to the Community!

 

That phone is compatible with our 2G and 3G frequencies, so you should be using the Fido-core-appl1.apn  APN. Is that the one you are trying with or did you enter the LTEMOBILE.APN one?

 

Let us know Smiley



anerev
I'm a Participant Level 2

Thanks a lot for your reply!!

Really happy to hear that my phone is compatible (in theory, at least)...

Yeah, I used the fido-core-appl1.apn...

Is there something else I could try?

 

Thanks!!

 

 

Always happy to help Smiley

 

Can you enable Data Roaming in your settings? Sounds weird, since you're not roaming, but sometimes the phone can think it's roaming if it's not on its "home" network.

 

Keep us posted!



anerev
I'm a Participant Level 2

WOW!! That just did the trick!! THANKS SO MUCH!!!!

 

(now I just have to watch out to turn the data roaming off when I go travelling!!)

 

Awesome! Glad it's workin! And yes, be sure to turn it off again when you leave the country Wink

 

Cheers!