cancel
Showing results for 
Search instead for 
Did you mean: 

SIM not registered to network

parthasarathy
I'm a Participant Level 2
I'm a Participant Level 2

 

 

I ported a number from Chatr to Fido and since then have not been able to use my phone for calls/SMS/Data. I see the error as 'Not registered on network'.

 

I tried customer support, tech support and in store support. I was given replacement SIMS but even they did not work. I tried the given SIMS on multiple devices and found the same issue everywhere , so its not an issue with the device.

 

Any advice in this regard would be very helpful.

 

3 REPLIES 3

parthasarathy
I'm a Participant Level 2
I'm a Participant Level 2

The SIM card was activated. Yes, they did try it on one of their phones. They then asked me to finally contact the tech support. However, the tech support has not been able to help me either. It has been 2 days of no service now.

Hello, again @parthasarathy,

 

Strange, I would suggest you contact customer service and double-check the SIM number with them if it's all good ask them to do a reset to switch on your line then restart your device and see if it helps.



KAPABLE-K
MVP MVP
MVP

Hello @parthasarathy,

 

Welcome to the community!

 

This is a very odd situation, might sound stupid but was the SIM card activated? When you went to the Fido store did they try it on one of their phones?