RCS not working

Reply
I'm a Participant Level 2 Ansh1
I'm a Participant Level 2

RCS not working

I recently bought an unlocked pixel 3, and put my Fido RCS sim card in it. But I have found RCS is not working. Whenever I go into Android messages settings and enable it, I get a losing screen for a few seconds, then it says "excuse the wait" and that it'll let me know when it's done (which it never does). I have tried erasing my cache, and the storage, as well as rebooting the phone but nothing seems to work. I did some research and found that Fido might need to reset my RCS profile, but the phone costumer support may have trouble understanding, so I'm hoping a supervisor or someone on this forum can help me?

Accepted Solution

Re: RCS not working

I have RCS working now, though I do not know if anything was done on Fido's end. But I followed the instructions in this thread -- https://forums.fido.ca/t5/forums/forumtopicpage/board-id/Smartphones/message-id/39244#M39244

 

For reference, here's what I did on my BYOD Pixel 2:

  1. Open Messages app
  2. Go to Play Store, search for "carrier services"
  3. Click on "Carrier Services" by Google LLC, which should be at the top of the results and show as installed
  4. Click on "Uninstall" and you'll be prompted as "Do you want to uninstall all updates to this Android system app?"
  5. Click "OK"
  6. Go back to the Messages app
  7. Go to Messages settings within the three dots "..." menu
  8. Go to the "Advanced" tab and click on "Enable Chat Features"
  9. You should see a small circle, followed by a bigger circle with a checkmark in the middle -- success!
  10. Go back to the "Carrier Services" app in the Play Store and click on "Update" to re-install any updates

 

YMMV but it worked for me.

 

Cheers,

Douglas

View solution in context
Flag this to a Moderator
Message 1 of 15
1,295 Views
Moderator
Moderator

Re: RCS not working

Hey @8563049

 

Congrats on your first post!

 

I'll send you a PM soon so we can look into this with you. Smiley

 

On a side note, have you tried the solution proposed here.

 

Talk soon.



Flag this to a Moderator
Message 11 of 15
390 Views
I'm a Contributor Level 1 wrick
I'm a Contributor Level 1

Re: RCS not working

Just posting in here to get notified if anyone else gets this solved.

 

I've been struggling for weeks with support to get this working too.  To no avail.

 

BYOD Pixel 3.

Flag this to a Moderator
Message 12 of 15
382 Views
I'm a Participant Level 2 DouglasRR
I'm a Participant Level 2
Solution

Re: RCS not working

I have RCS working now, though I do not know if anything was done on Fido's end. But I followed the instructions in this thread -- https://forums.fido.ca/t5/forums/forumtopicpage/board-id/Smartphones/message-id/39244#M39244

 

For reference, here's what I did on my BYOD Pixel 2:

  1. Open Messages app
  2. Go to Play Store, search for "carrier services"
  3. Click on "Carrier Services" by Google LLC, which should be at the top of the results and show as installed
  4. Click on "Uninstall" and you'll be prompted as "Do you want to uninstall all updates to this Android system app?"
  5. Click "OK"
  6. Go back to the Messages app
  7. Go to Messages settings within the three dots "..." menu
  8. Go to the "Advanced" tab and click on "Enable Chat Features"
  9. You should see a small circle, followed by a bigger circle with a checkmark in the middle -- success!
  10. Go back to the "Carrier Services" app in the Play Store and click on "Update" to re-install any updates

 

YMMV but it worked for me.

 

Cheers,

Douglas

Flag this to a Moderator
Message 13 of 15
377 Views
I'm a Contributor Level 1 wrick
I'm a Contributor Level 1

Re: RCS not working

Oh it worked !

 

 

 

 

Flag this to a Moderator
Message 14 of 15
373 Views
Highlighted
Moderator
Moderator

Re: RCS not working

Thanks for sharing with everyone, @DouglasRR!

 

 



Flag this to a Moderator
Message 15 of 15
345 Views
Discussion stats
  • 14 replies
  • 1296 views
  • 9 likes
  • 11 in conversation