No LTE in Halifax

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

No LTE in Halifax

I was with chatr and I got a text saying to move to Fido we give you LTE. It’s been a couple of days of me roaming around the city looking for any place where I actually get a LTE signal. I have found none. 

are there anyone else here with similar challenges

 

my phone is an Unlocked iPhone X I think it should be picking up LTE signal well enough 

 

I have tried posting my details doing a signal check but I have not got any response yet from Fido 

Flag this to a Moderator
Message 1 of 3
203 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: No LTE in Halifax

Hello Dk99,

 

  Welcome to the community!

 

  When you inserted your new SIM from Fido, did you update your phone's carrier settings? If not, you can do so by following the instructions here. Similar to APNs on android devices your phone would need the proper carrier settings to access the LTE networks. If your phone still is the carrier settings from Chatr, that could be the reason you're unable to access the LTE networks.

 

  There should be LTE in Halifax. You can get an idea of the cellular towers in the area here. The frequencies associated with LTE on the Fido/Rogers network are 2100MHz, 2600MHz, and 700MHz on that map (see here).

 

Hope this helps 😀

 

Cheers

 


Flag this to a Moderator
Message 2 of 3
199 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: No LTE in Halifax

Honestly I tried all that before writing here. But the good thing without doing anything I got the LTE on all I had to do was post it here.

 

i don’t know if that’s a part of requirement to get LTE

Flag this to a Moderator
Message 3 of 3
163 Views