MMS problem with Verizon unlocked S5

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

MMS problem with Verizon unlocked S5

Hi all,

 

I have recently received an unlocked cell phone (Samsung s5) from Verizon. I have followed  the fido website to enter the proper apn settings. I am currently able to send and receive sms and use the 4G lte data for internet. However I am just not able to send or receive mms, and yes I have turned on my data. I have done a factory reset, I have rooted my phone trying to delete the locked apn setting from Verizon, but it just won't go away, and now i am just out of ideas. Would anyone have fixed a problem similar to that? Please help 😂

 

Accepted Solution

Re: MMS problem with Verizon unlocked S5

Hello again,

 

  Hmm... Have you verified that the APN type in your APN settings includes MMS? That is, does it specify internet + MMS or default,MMS? Also, just to double check, you can verify the other settings here.

 

Hope this helps Smiley

 

Cheers

View solution in context
Flag this to a Moderator
Message 1 of 6
3,522 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: MMS problem with Verizon unlocked S5

Hello Viviy228,

 

  Welcome to the community!

 

  According to these specifications from the Samsung website,

 

Frequencies and Data Type

LTE: Bands 4/13; CDMA 1x/EVDO Rev.A: 800/1900MHz; GSM: 850/900/1800/1900MHz; HSPA+/UMTS: 850/900/1900/2100MHz

 

  That phone has all of the compatible bands/frequencies for 2G and '3G'. With regards to LTE, that phone only has one of the compatible bands/frequencies, band 4 or 1700/2100MHz. You can verify the compatible bands/frequencies here. You should note that coverage would depend on your surrounding celluar towers having corresponding bands/frequences. You can view your surrounding towers here.

 

  Are you able to make/receive calls?

 

  Since Verizon's main network is CDMA (not compatible with GSM), have you verified that your Network mode is set to GSM/UMTS/LTE? Have you tried to enable roaming? Some devices might think they are roaming when they are not used within their intended market area, even though they use a local SIM.

 

  I understand you entered the proper APN settings. Does the phone allow you to save those setting? Is the phone allowing you to select that APN or does it always default to Verizon's APN?

 

Hope this helps Smiley

 

Cheers

 


Flag this to a Moderator
Message 2 of 6
3,520 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: MMS problem with Verizon unlocked S5

Thanks for the reply.

Yes I'm able to make calls, I get the 4g LTE sign too.

Yes I'm able to add a new fido APN settings, save it and default to it. The only thing that is really missing is MMS. I saw online that a lot of people having MMS issue with Verizon unlocked phones.

Would you have other suggestions?

 

Flag this to a Moderator
Message 3 of 6
3,506 Views
Highlighted
Senior MVP Senior MVP
Senior MVP
Solution

Re: MMS problem with Verizon unlocked S5

Hello again,

 

  Hmm... Have you verified that the APN type in your APN settings includes MMS? That is, does it specify internet + MMS or default,MMS? Also, just to double check, you can verify the other settings here.

 

Hope this helps Smiley

 

Cheers


Flag this to a Moderator
Message 4 of 6
3,504 Views
Highlighted
Senior MVP Senior MVP
Senior MVP

Re: MMS problem with Verizon unlocked S5

Hello again,

 

  Something else I thought of... Is your phone connected to Wifi? I understand you have enabled your data. However, I've been having a weird glitch of sorts with my S5. If I'm connected to Wifi, I cannot send or receive MMS even though my data is enabled. I have to disable my Wifi before anything will send or get received via MMS. I've never bothered to investigate why it happens, I just disable my Wifi when required.

 

Just a thought...

 

Cheers


Flag this to a Moderator
Message 5 of 6
3,492 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: MMS problem with Verizon unlocked S5

O boy, you just fixed my problem, I put in default,MMS and it works now. It's so weird, I'm sure I have tried something similar before doing all those factory reset and rooting thing. Anyway as long as it works now! Million thanks! 😀

Flag this to a Moderator
Message 6 of 6
3,486 Views