Showing results for 
Search instead for 
Did you mean: 

Call Display-REmove Private Caller

I'm a participant level 1
I'm a participant level 1

Our phone caller displays now read Private Caller. We think it may have occurred after we removed the SIM when we were on vacation. When I log into the account both phones correctly have our names displayed, yet when we phone the display to our recipients says Private Caller. I have tried updating our names, but that has not worked.



Hey @Hero7 Smiley 

That's odd! Have you checked your phone settings to ensure your phone number isn't set to private? 

For iPhones : 

Open Settings ➡ Phone ➡ Show my Caller ID.
Ensure that this is set to ON.

For Androids:

  1. Open the Google Voice app 
  2. At the top left, tap the Menu and then Settings 
  3. Under “Calls,” turn off Anonymous caller ID.

If that doesn't do the trick, feel free to contact customer service and we can look into it.