Showing results for 
Search instead for 
Did you mean: 

Using your own router and gateway mode

I'm a participant level 2
I'm a participant level 2

I wanted to share my experience in case other have comments or help somebody - Read on if you have your own router


I signed up for Fido internet two weeks ago. I picked up the Hitron modem, connected to cable and all good. I have my own router so I disabled the Hitron modem gateway functionality and connected my router. All good.

Last night my router restarted (on a schedule for 4am) and in the morning I realized I didnt have internet. 

Restarted Hitron modem, nothing. Restarted router nothing. Called support and after some troubleshooting they asked me to replace the Hitron modem. I picked up a new one.

Initially it wouldnt complete the setup (failed to pass the internet test), called support and they made it work. Setup Hitron modem and it worked. When I disabled the gateway function and connected my router it wouldnt work.

I also noticed the Hitron modem was going into a "weird"state EVERY time it was in Bridge mode (i.e. gateway functionality is off)

  1. Setup hooking up an ethernet cable and connecting a computer directly to the Hittron modem (only device connected for testing, tried all ports on the Hitron modem, tried two separate computers)
    1. it would take a computer around 10 seconds to show it connected (normally ~1sec)
    2. There will be NO internet connectivity whatsoever for 3-5 minutes. Any browsing will give error.
    3. After this time, the will be some internet connectivity ( worked, youtube worked. did not worked, amazon did not worked)
    4. It is no longer possible to connect to Hitron modem webinterface
  2. My router would not get an ip address and therefore no connectivity at all

Only way to resolve this was to factory reset the modem. The moment gateway mode was disabled back to above situation

This would repeat with different computers and behaviour above was very consistent


At the end the technician have me change my configuration: on Hitron modem turned off wifi but not disabled gateway. Connect my router. Everything works

He was not able to explain why Hitron on bridge would not work when connecting my computer. He said it was because the gateway functionality was off and the weird behaviour above is "normal" when gateway if off. And it should be resolve if I connected my router but likely my router was not properly setup???


I think this is BS


At that point, at this point it was 4pm already. I had made through the day three calls to Fido (each involved 20-30 wait to speak with support who them put me to wait 30-50 min to speak with tech support and then 30-60 min conversation with tech support).


I was tired so just left the configuration the way he suggested.


I hope other dont waste a good part of the day like I did



Hey @Arcegabriel Smiley


Although, as Community mods, we do not offer technical support for the Home Internet service, perhaps other Community members will have some tips or feedback for you!


If you do still need help with your account and don't wish to call in though, you can reach out to Tech Support over Live Chat 24/7.



I'm a participant level 2
I'm a participant level 2


I will probably be doing some more research on this... Appreciate feedback

BTW my comment about not been able to access the modem in bridge mode apply to and There is no way to access it for me until I factory reset. Fido tech was able to access on his side

Now everything I have setup relying on port forwarding (external access) doesnt work since there are two gateways...


I'm a participant level 1
I'm a participant level 1



I am experiencing exactly the same thing you are. I have not contacted tech support or replaced the modem.


My modem is CGN3 and firmware version is


Please let me know if you found a solution.


I will say, I was able to connect to modem at after manually changing my computer IP to Otherwise, since the modem is not supplying an IP, the computer isn't able to connect to the modems login page.


It is very frustrating to have this happen every day, especially since I'm relying on the connection to work from home. This never happened prior to this weekens when I set up this modem. I was on Rogers before that and had no issues at all in bridge mode. 

I'm a participant level 2
I'm a participant level 2

The problem happened on firmware #37 and resolved after a tech visit + new modem + modem upgrading to #38 (Still the black modem).

Sorry couldnt exactly pinpoint. I know one modem with #38 was still funky and had to be replaced